Fix bugs 167768 166992 161592.
authorSamuli Suominen <ssuominen@gentoo.org>
Wed, 21 Feb 2007 19:44:50 +0000 (19:44 +0000)
committerSamuli Suominen <ssuominen@gentoo.org>
Wed, 21 Feb 2007 19:44:50 +0000 (19:44 +0000)
Package-Manager: portage-2.1.2-r10

x11-themes/tango-icon-theme-extras/ChangeLog
x11-themes/tango-icon-theme-extras/files/digest-tango-icon-theme-extras-0.1.0-r1 [new file with mode: 0644]
x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild [new file with mode: 0644]
x11-themes/tango-icon-theme/ChangeLog
x11-themes/tango-icon-theme/files/digest-tango-icon-theme-0.8.0 [new file with mode: 0644]
x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild [new file with mode: 0644]

index 730e8182fca951958b002ca27da20d4e0feb8780..a3e1ae008d75fa0258b6190038f1573be9976f26 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-themes/tango-icon-theme-extras
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme-extras/ChangeLog,v 1.9 2006/10/27 17:00:06 metalgod Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme-extras/ChangeLog,v 1.10 2007/02/21 19:43:13 drac Exp $
+
+*tango-icon-theme-extras-0.1.0-r1 (21 Feb 2007)
+
+  21 Feb 2007; Samuli Suominen <drac@gentoo.org>
+  +tango-icon-theme-extras-0.1.0-r1.ebuild:
+  Fix bugs 167768 166992 161592.
 
   27 Oct 2006; Luis Medinas <metalgod@gentoo.org>
   tango-icon-theme-extras-0.1.0.ebuild:
diff --git a/x11-themes/tango-icon-theme-extras/files/digest-tango-icon-theme-extras-0.1.0-r1 b/x11-themes/tango-icon-theme-extras/files/digest-tango-icon-theme-extras-0.1.0-r1
new file mode 100644 (file)
index 0000000..218a555
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 caaceaec7b61f1cbda0db9842f9db281 tango-icon-theme-extras-0.1.0.tar.gz 228375
+RMD160 7c301bbe6748fc770bc52f91624ce676624d00e3 tango-icon-theme-extras-0.1.0.tar.gz 228375
+SHA256 b9252179ea2c546e6bb065281d51373f0ae06081e5a98d4255249af4fa8b33db tango-icon-theme-extras-0.1.0.tar.gz 228375
diff --git a/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild b/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..625f4fc
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild,v 1.1 2007/02/21 19:43:13 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="This is an extension to the Tango Icon Theme. It includes Tango icons for iPod Digital Audio Player (DAP) devices and the Dell Pocket DJ DAP."
+HOMEPAGE="http://tango-project.org/"
+SRC_URI="http://tango-project.org/releases/${P}.tar.gz"
+
+LICENSE="CCPL-Attribution-ShareAlike-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="png"
+
+RESTRICT="binchecks strip"
+
+RDEPEND=">=x11-misc/icon-naming-utils-0.6.0
+       media-gfx/imagemagick
+       >=gnome-base/librsvg-2.12.3"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+pkg_setup() {
+       if use png && ! built_with_use media-gfx/imagemagick png; then
+               die "Build media-gfx/imagemagick with USE=png."
+       fi
+}
+
+src_compile() {
+       if use png; then
+               econf --enable-png-creation
+       else
+               econf
+       fi
+
+       emake || die "emake failed."
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || "emake install failed."
+       dodoc AUTHORS ChangeLog NEWS README
+}
index e186bb5b4c1e6cd5252de5bc28462e2edaedd0ad..c388224f9db5f5985e50f7b5f17aa2d4e1835aff 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-themes/tango-icon-theme
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/ChangeLog,v 1.22 2006/09/30 19:32:32 dang Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/ChangeLog,v 1.23 2007/02/21 19:44:50 drac Exp $
+
+*tango-icon-theme-0.8.0 (21 Feb 2007)
+
+  21 Feb 2007; Samuli Suominen <drac@gentoo.org>
+  +tango-icon-theme-0.8.0.ebuild:
+  Fix bugs 167768 166992 161592.
 
   30 Sep 2006; Daniel Gryniewicz <dang@gentoo.org>
   tango-icon-theme-0.7.2.ebuild:
diff --git a/x11-themes/tango-icon-theme/files/digest-tango-icon-theme-0.8.0 b/x11-themes/tango-icon-theme/files/digest-tango-icon-theme-0.8.0
new file mode 100644 (file)
index 0000000..6a6d5bf
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 feb1870e84b99ea41db9b51a448c59f8 tango-icon-theme-0.8.0.tar.gz 1770650
+RMD160 02a7c384f4640b978c7cb1413f3ca5888113676f tango-icon-theme-0.8.0.tar.gz 1770650
+SHA256 6745cb47b9b0d54bfec7cc0a77c0789cf41935b04f9c8f7c4a78e165cf92e419 tango-icon-theme-0.8.0.tar.gz 1770650
diff --git a/x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild
new file mode 100644 (file)
index 0000000..cdb9607
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild,v 1.1 2007/02/21 19:44:50 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="SVG icon theme from the Tango project"
+HOMEPAGE="http://tango-project.org/"
+SRC_URI="http://tango-project.org/releases/${P}.tar.gz"
+
+LICENSE="CCPL-Attribution-ShareAlike-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="png"
+
+RESTRICT="binchecks strip"
+
+RDEPEND=">=x11-misc/icon-naming-utils-0.8.2
+        media-gfx/imagemagick
+        >=gnome-base/librsvg-2.12.3"
+DEPEND="${RDEPEND}
+       >=dev-util/pkgconfig-0.19
+       >=dev-util/intltool-0.33
+       sys-devel/gettext"
+
+pkg_setup() {
+       if use png && ! built_with_use media-gfx/imagemagick png; then
+               die "Build media-gfx/imagemagick with USE=png."
+       fi
+}
+
+src_compile() {
+       if use png; then
+               econf --enable-png-creation
+       else
+               econf
+       fi
+
+       emake || die "emake failed."
+}
+
+src_install() {
+       emake DESTDIR=${D} install || die "emake install failed."
+       dodoc AUTHORS ChangeLog NEWS README
+}