sys-apps/arrayprobe: Port to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sat, 2 Dec 2017 15:21:05 +0000 (16:21 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 2 Dec 2017 16:14:50 +0000 (17:14 +0100)
Package-Manager: Portage-2.3.16, Repoman-2.3.6

sys-apps/arrayprobe/Manifest
sys-apps/arrayprobe/arrayprobe-2.0-r2.ebuild
sys-apps/arrayprobe/files/2.0-ida_headers.patch
sys-apps/arrayprobe/files/2.0-malloc-strlen.patch

index f5eec1d056311d95f57354e26ee29248d12dbda5..b514c97f48f38b9070b663724dcd5b4837b89ded 100644 (file)
@@ -1 +1 @@
-DIST arrayprobe-2.0.tar.gz 83831 SHA256 ccb560b5c7e8b378d110cad6e9245884e7e673acfa3c4016ef33acd699f1f4d0 SHA512 4664e20604697edf2f848447419b26ff860dd302b3d3e5aa0f3977855c590b5acbe23c39b684a2ecb1603c86cf7762e86bfc7125421ccad7f322e387c4178870 WHIRLPOOL 56eec2322f806f25e411614e12e9c584208202203f6d070846c73d04c0b379103ad2c45d3a6638a8cf6d66ea51173fbf0dcd91af3b01702a39848bb8a503cd34
+DIST arrayprobe-2.0.tar.gz 83831 BLAKE2B 6a9b76260c91b271068be914161bd99c4ce2285c58ce98c689f6bef32200701430bb65306e74a1d9277d7a4d9e4aa0adf4af60af0c4264020ae07a73f49a51de SHA512 4664e20604697edf2f848447419b26ff860dd302b3d3e5aa0f3977855c590b5acbe23c39b684a2ecb1603c86cf7762e86bfc7125421ccad7f322e387c4178870
index 98fae16e76826d039ba37eff5c95e692923c1505..5f961969810b9fdfcac3d8c5a1b3a7245c6b0238 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI=6
 
-inherit eutils autotools
+inherit autotools
 
 DESCRIPTION="Utility to report status of an HP (Compaq) array controller (both IDA & CCISS)"
 HOMEPAGE="http://www.strocamp.net/opensource/arrayprobe.php"
@@ -14,8 +14,12 @@ SLOT="0"
 KEYWORDS="amd64 ~ia64 x86"
 IUSE=""
 
+PATCHES=(
+       "${FILESDIR}/${PV}-malloc-strlen.patch"
+       "${FILESDIR}/${PV}-ida_headers.patch"
+)
+
 src_prepare() {
-       epatch "${FILESDIR}/${PV}-malloc-strlen.patch"
-       epatch "${FILESDIR}/${PV}-ida_headers.patch"
+       default
        eautoreconf
 }
index fbdb20b87ea6dbe1f02659f5f3b85038a2b2f719..3cd744b32a33f45f2a6a3e01fef64db53630466f 100644 (file)
@@ -1,6 +1,5 @@
-diff -Naur arrayprobe-2.0.old/cciss_events.h arrayprobe-2.0/cciss_events.h
---- arrayprobe-2.0.old/cciss_events.h  2005-12-27 10:51:29.000000000 +0100
-+++ arrayprobe-2.0/cciss_events.h      2010-01-13 15:46:53.000000000 +0100
+--- a/cciss_events.h
++++ b/cciss_events.h
 @@ -27,8 +27,12 @@
  #define QWORD __u64
  
@@ -14,9 +13,8 @@ diff -Naur arrayprobe-2.0.old/cciss_events.h arrayprobe-2.0/cciss_events.h
  
  #define CompareEvent(event,par_class,par_subclass,par_detail) \
                       ((event.class.class==par_class) && \
-diff -Naur arrayprobe-2.0.old/configure.ac arrayprobe-2.0/configure.ac
---- arrayprobe-2.0.old/configure.ac    2006-01-03 13:58:31.000000000 +0100
-+++ arrayprobe-2.0/configure.ac        2010-01-13 15:42:49.000000000 +0100
+--- a/configure.ac
++++ b/configure.ac
 @@ -19,38 +19,6 @@
  dnl Check for compile.h (2.6.x kernels only?
  AC_CHECK_HEADERS(linux/compiler.h)
@@ -56,9 +54,8 @@ diff -Naur arrayprobe-2.0.old/configure.ac arrayprobe-2.0/configure.ac
  # Checks for typedefs, structures, and compiler characteristics.
  AC_C_CONST
  
-diff -Naur arrayprobe-2.0.old/cpqarray.h arrayprobe-2.0/cpqarray.h
---- arrayprobe-2.0.old/cpqarray.h      1970-01-01 01:00:00.000000000 +0100
-+++ arrayprobe-2.0/cpqarray.h  2010-01-13 15:40:11.000000000 +0100
+--- a/cpqarray.h
++++ b/cpqarray.h
 @@ -0,0 +1,126 @@
 +/*
 + *    Disk Array driver for Compaq SMART2 Controllers
@@ -186,9 +183,8 @@ diff -Naur arrayprobe-2.0.old/cpqarray.h arrayprobe-2.0/cpqarray.h
 +#endif
 +
 +#endif /* CPQARRAY_H */
-diff -Naur arrayprobe-2.0.old/ida_cmd.h arrayprobe-2.0/ida_cmd.h
---- arrayprobe-2.0.old/ida_cmd.h       1970-01-01 01:00:00.000000000 +0100
-+++ arrayprobe-2.0/ida_cmd.h   2010-01-13 15:40:29.000000000 +0100
+--- a/ida_cmd.h
++++ b/ida_cmd.h
 @@ -0,0 +1,349 @@
 +/*
 + *    Disk Array driver for Compaq SMART2 Controllers
@@ -539,9 +535,8 @@ diff -Naur arrayprobe-2.0.old/ida_cmd.h arrayprobe-2.0/ida_cmd.h
 +#pragma pack()        
 +
 +#endif /* ARRAYCMD_H */
-diff -Naur arrayprobe-2.0.old/ida_ioctl.h arrayprobe-2.0/ida_ioctl.h
---- arrayprobe-2.0.old/ida_ioctl.h     1970-01-01 01:00:00.000000000 +0100
-+++ arrayprobe-2.0/ida_ioctl.h 2010-01-13 15:44:46.000000000 +0100
+--- a/ida_ioctl.h
++++ b/ida_ioctl.h
 @@ -0,0 +1,87 @@
 +/*
 + *    Disk Array driver for Compaq SMART2 Controllers
@@ -630,9 +625,8 @@ diff -Naur arrayprobe-2.0.old/ida_ioctl.h arrayprobe-2.0/ida_ioctl.h
 +} ida_ioctl_t;
 +
 +#endif /* IDA_IOCTL_H */
-diff -Naur arrayprobe-2.0.old/probe.c arrayprobe-2.0/probe.c
---- arrayprobe-2.0.old/probe.c 2006-01-03 14:11:17.000000000 +0100
-+++ arrayprobe-2.0/probe.c     2010-01-13 15:45:22.000000000 +0100
+--- a/probe.c
++++ b/probe.c
 @@ -33,10 +33,9 @@
  #include <getopt.h>
  #include <errno.h>
index 8d955a8f933d51725c6a2177d51dfd3aef0884bd..2732f75b939a36438be5802128b9de27cba74674 100644 (file)
@@ -1,5 +1,5 @@
---- probe.c.old        2010-01-13 12:15:32.000000000 +0100
-+++ probe.c    2010-01-13 12:16:44.000000000 +0100
+--- a/probe.c
++++ b/probe.c
 @@ -354,7 +354,7 @@
        int drivenum = event.detail.logstatchange.logicaldrivenumber;
        logdrvs[drivenum].state.state = event.detail.logstatchange.newlogicaldrivestate;