www-client/netsurf: Remove unused fbcon_frontend_* flags
authorMichał Górny <mgorny@gentoo.org>
Mon, 23 Sep 2019 08:00:44 +0000 (10:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 23 Sep 2019 08:07:15 +0000 (10:07 +0200)
Closes: https://bugs.gentoo.org/695158
Signed-off-by: Michał Górny <mgorny@gentoo.org>
www-client/netsurf/metadata.xml
www-client/netsurf/netsurf-3.8-r2.ebuild

index 80316470ae4777e16146a1b10d8469c20093c3d5..152de9fcc3c6610b3e17a25296d1fc3194b9465e 100644 (file)
@@ -7,16 +7,13 @@
 </upstream>
 <use>
        <flag name="bmp">BMP bitmap image support (media-libs/libnsbmp)</flag>
-       <flag name="fbcon_frontend_sdl">Use framebuffer frontend sdl</flag>
-       <flag name="fbcon_frontend_vnc">Use framebuffer frontend vnc</flag>
-       <flag name="fbcon_frontend_x">Use framebuffer frontend X</flag>
+       <flag name="duktape">Use duktape.org javascript engine</flag>
+       <flag name="gtk">Build GTK3 GUI</flag>
+       <flag name="gtk2">Build GTK2 GUI</flag>
        <flag name="pdf-writer">PDF output support (media-libs/libharu)</flag>
+       <flag name="psl">Use public suffix list via media-libs/libnspsl</flag>
        <flag name="rosprite">RISC OS Sprite bitmap image support (media-libs/librosprite)</flag>
        <flag name="svgtiny">SVG image support via media-libs/svgatiny instead of gnome-base/librsvg</flag>
-       <flag name="psl">Use public suffix list via media-libs/libnspsl</flag>
-       <flag name="gtk">Build GTK3 GUI</flag>
-       <flag name="gtk2">Build GTK2 GUI</flag>
-       <flag name="duktape">Use duktape.org javascript engine</flag>
 </use>
 <longdescription lang="en">
 NetSurf is a free, open source web browser. It is written in C, has its own layout and rendering engine entirely written from scratch. It is small and capable of handling many of the web standards in use today.
index e2c03b5e2c98da3073085b09e9a040ec9867b52b..e9cd87acae48aa2c9791d5c9e80bfe7997c926e3 100644 (file)
@@ -13,11 +13,9 @@ LICENSE="GPL-2 MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
 IUSE="+bmp +duktape fbcon truetype +gif gtk gtk2 +javascript +jpeg +mng
-       pdf-writer +png +psl +rosprite +svg +svgtiny +webp fbcon_frontend_sdl
-       fbcon_frontend_vnc fbcon_frontend_x"
+       pdf-writer +png +psl +rosprite +svg +svgtiny +webp"
 
 REQUIRED_USE="|| ( fbcon gtk gtk2 )
-       fbcon? ( || ( fbcon_frontend_sdl fbcon_frontend_vnc fbcon_frontend_x ) )
        duktape? ( javascript )"
 
 RDEPEND="
@@ -115,12 +113,6 @@ src_install() {
                elog "framebuffer binary has been installed as netsurf-fb"
                make_desktop_entry "${EROOT}"/usr/bin/netsurf-fb NetSurf-framebuffer netsurf "Network;WebBrowser"
        fi
-       if use fbcon_frontend_sdl; then
-               elog "To be able to use netsurf without X, don't forget to enable the "
-               elog "proper USE flags in libsdl (fbcon). Also, make /dev/input/mice "
-               elog "readable to the account using netsurf-fb. Either use chmod a+r "
-               elog "/dev/input/mice (security!!!) or use a group."
-       fi
        if use gtk2 ; then
                _emake TARGET=gtk DESTDIR="${ED}" install
                elog "netsurf gtk2 version has been installed as netsurf-gtk"