x11-wm/amiwm: Version bump to 0.22.01_p20200826 snapshot
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 26 Apr 2020 21:04:26 +0000 (22:04 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Thu, 7 May 2020 22:24:21 +0000 (23:24 +0100)
It has a new (but somewhat dead) upstream. I sent a bunch of patches
to fix all the build issues though.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
x11-wm/amiwm/Manifest
x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild [new file with mode: 0644]

index f22c0a66448a9431dea4aefe05a6553e12b41613..39acc8033f5d72434e06e3ca7797d8ce53816d6b 100644 (file)
@@ -1 +1,2 @@
+DIST amiwm-0.22.01_p20200826.tar.gz 153787 BLAKE2B eebd61436bff6c063c0946f61632f5a56ba01d62f01e2761de62fed1c2c5049a191dbbaf836ac0b0771b38a84dc6f52a40ee53b9c73666855cfe03b6a829f9a8 SHA512 a4329eb8ea98b631611a6e069f27a6c640bfac94aa5a2c3591c9c35c4b08ea6f123fadcd56597353b27ec67bc079e8268e1b700fe85c0d545c9bb93439362c1b
 DIST amiwm0.21pl2.tar.gz 195128 BLAKE2B de7c843e6b756797b7a72a8e0b6fde6d4c02893e3eae8262d85d4417a7ad6309c10add802c04dde2d092bc7c8a604edbc96c4a9fc3c7f1166897a7933a978ccb SHA512 6504a4fd4c30a571b0c501b46fdc442fcc993c27b4595753f7bfa12a38c0b997a01d939c7a35e6c499aa0f8972bc0fda7cc88a9fe77091f363f8cd5a9e8d50de
diff --git a/x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild b/x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild
new file mode 100644 (file)
index 0000000..7e7eaed
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+COMMIT="8b8c956a904fa73edb02d4dc6d45bc0358bff3b3"
+DESCRIPTION="Amiga Workbench inspired window manager for Xorg"
+HOMEPAGE="https://github.com/redsPL/amiwm"
+SRC_URI="https://github.com/chewi/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="amiwm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMON_DEPEND="
+       x11-libs/libX11
+       x11-libs/libXmu
+       x11-libs/libXext
+"
+
+RDEPEND="
+       ${COMMON_DEPEND}
+       media-fonts/font-misc-misc[nls,X]
+       x11-apps/xrdb
+       x11-apps/xsetroot
+"
+
+DEPEND="
+       ${COMMON_DEPEND}
+       x11-base/xorg-proto
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+       default
+       eautoconf
+}
+
+src_install() {
+       emake install DESTDIR="${D}" STRIPFLAG=
+       einstalldocs
+
+       exeinto /etc/X11/Sessions
+       newexe - ${PN} <<-EOF
+               #!/bin/sh
+               exec ${PN}
+       EOF
+}