sci-mathematics/gmp-ecm: cleanup old versions.
authorMichael Orlitzky <mjo@gentoo.org>
Mon, 9 Mar 2020 13:37:01 +0000 (09:37 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Mon, 9 Mar 2020 13:37:01 +0000 (09:37 -0400)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-mathematics/gmp-ecm/Manifest
sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild [deleted file]
sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r1.ebuild [deleted file]

index 1459ba43224603e09e583372a6dbd966a5623b31..d960832dd1a2ab28907664426cdbfa7add1dcd3a 100644 (file)
@@ -1,2 +1 @@
-DIST gmp-ecm-6.4.4.tar.gz 941058 BLAKE2B e83f02592a8bb86285f258fefc3e302cc5168888109e7f87835b25412baf526df58e5ea38347acfd926b90fac15b4103981a14aa7b853dba0cb0168467a223e0 SHA512 039009de2d1a22de7abed2e2b843fa2bc684ddcfc45892891a24b93ad4b3640a97d2e7612ebcbdbca8db032534c226ad77c67199772b21a6139e5fa205687097
 DIST gmp-ecm-7.0.4.tar.gz 1101899 BLAKE2B 6d52364d9c752aee66510a7f6b273559bf1b7de0032fbbeff74e229ed68fd0cd1c236b480f8fc25bcad6435740e3e22b3099c8f018912918ab8f4b33dc7b8b3c SHA512 b863b9bfd26df26c3c4243686036a69110e69ca3eec5b31d4550fe713e2fac4ce70cd1d80f0614899793aa44710531aa4a21abc0fa1b99eb17f62bd92b971350
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild
deleted file mode 100644 (file)
index 463c145..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic multilib
-
-DESCRIPTION="Elliptic Curve Method for Integer Factorization"
-HOMEPAGE="http://ecm.gforge.inria.fr/"
-SRC_URI="https://gforge.inria.fr/frs/download.php/32159/${P}.tar.gz"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+blas +custom-tune -openmp static-libs test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-libs/gmp:0=
-       blas? ( sci-libs/gsl )
-       openmp? ( sys-devel/gcc:*[openmp] )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/ecm-${PV}
-
-MAKEOPTS+=" -j1"
-
-src_prepare() {
-       sed -e '/libecm_la_LIBADD/s:$: -lgmp:g' -i Makefile.am || die
-       eautoreconf
-}
-
-src_configure() {
-       # --enable-shellcmd is broken
-       econf \
-               --enable-shared \
-               $(use_enable static-libs static) \
-               $(use_enable openmp) \
-               ${myconf}
-}
-
-src_compile() {
-       append-ldflags "-Wl,-z,noexecstack"
-       if use custom-tune; then
-               use amd64 && cd x86_64
-               use x86 && cd pentium4
-               emake
-               cd .. && make bench_mulredc || die
-               sed -i -e 's:#define TUNE_MULREDC_TABLE://#define TUNE_MULREDC_TABLE:g' `readlink ecm-params.h` || die
-               sed -i -e 's:#define TUNE_SQRREDC_TABLE://#define TUNE_SQRREDC_TABLE:g' `readlink ecm-params.h` || die
-               ./bench_mulredc | tail -n 4 >> `readlink ecm-params.h` || die
-       fi
-       default
-}
-
-src_install() {
-       default
-       mkdir -p "${ED}/usr/include/${PN}/"
-       cp "${S}"/*.h "${ED}/usr/include/${PN}" || die "Failed to copy headers" # needed by other apps like YAFU
-}
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r1.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r1.ebuild
deleted file mode 100644 (file)
index e650e69..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic multilib
-
-DESCRIPTION="Elliptic Curve Method for Integer Factorization"
-HOMEPAGE="http://ecm.gforge.inria.fr/"
-SRC_URI="https://gforge.inria.fr/frs/download.php/36224/${P}.tar.gz"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+blas +custom-tune -openmp static-libs test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-libs/gmp:0=
-       blas? ( sci-libs/gsl )
-       openmp? ( sys-devel/gcc:*[openmp] )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/ecm-${PV}
-
-MAKEOPTS+=" -j1"
-
-src_prepare() {
-       sed -e '/libecm_la_LIBADD/s:$: -lgmp:g' -i Makefile.am || die
-       eautoreconf
-}
-
-src_configure() {
-       # --enable-shellcmd is broken
-       econf \
-               --enable-shared \
-               $(use_enable static-libs static) \
-               $(use_enable openmp) \
-               ${myconf}
-}
-
-src_compile() {
-       append-ldflags "-Wl,-z,noexecstack"
-       if use custom-tune; then
-               emake && emake ecm-params # need to build all to get benchmark bits, then run benchmark
-               emake
-       fi
-       default
-}
-
-src_install() {
-       default
-       mkdir -p "${ED}/usr/include/${PN}/"
-       cp "${S}"/*.h "${ED}/usr/include/${PN}" || die "Failed to copy headers" # needed by other apps like YAFU
-}