dev-cpp/cpp-taskflow: new package
authorMatthias Maier <tamiko@gentoo.org>
Sat, 23 May 2020 07:00:33 +0000 (02:00 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sat, 23 May 2020 07:00:33 +0000 (02:00 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
dev-cpp/cpp-taskflow/Manifest [new file with mode: 0644]
dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild [new file with mode: 0644]
dev-cpp/cpp-taskflow/metadata.xml [new file with mode: 0644]

diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
new file mode 100644 (file)
index 0000000..4c62f18
--- /dev/null
@@ -0,0 +1 @@
+DIST cpp-taskflow-2.4.0.tar.gz 76993334 BLAKE2B 8f257165ab72dbe6c1cf6a86886669008e9f16f1dfd4871defc452bdb9dfa3e45ab9bfbbdc874b4ba566a2a7d8984a666ce2933b2c6d2215467f7fbfa03ac520 SHA512 dd6c7500e39d7058871280d12e120bd28d9609e5289f1d7851b3b59e2c1bfe74d3040d902bd5b26895e558b563c8abad878e7bc343e199e7356940c02a64217f
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild
new file mode 100644 (file)
index 0000000..a41d261
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+HTML_DOCS=( docs/. )
+
+src_install() {
+       insinto /usr/include
+       doins -r taskflow
+
+       if $(use doc); then
+               einstalldocs
+       fi
+}
diff --git a/dev-cpp/cpp-taskflow/metadata.xml b/dev-cpp/cpp-taskflow/metadata.xml
new file mode 100644 (file)
index 0000000..8406ef2
--- /dev/null
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>tamiko@gentoo.org</email>
+               <name>Matthias Maier</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>sci@gentoo.org</email>
+               <name>Gentoo Science Project</name>
+       </maintainer>
+       <longdescription>
+               Cpp-Taskflow is faster, more expressive, and easier for drop-in
+               integration than many of existing task programming frameworks in
+               handling complex parallel workloads.
+       </longdescription>
+       <upstream>
+               <remote-id type="github">cpp-taskflow/cpp-taskflow</remote-id>
+       </upstream>
+</pkgmetadata>