Bug #269225 - Warn about virtuals with non-empty HOMEPAGE or LICENSE. Thanks
authorZac Medico <zmedico@gentoo.org>
Thu, 7 Jan 2010 20:19:54 +0000 (20:19 -0000)
committerZac Medico <zmedico@gentoo.org>
Thu, 7 Jan 2010 20:19:54 +0000 (20:19 -0000)
to Ulrich Müller <ulm@g.o> for this patch.

svn path=/main/trunk/; revision=15174

bin/repoman
man/repoman.1

index 592e273726fd2b030462a2e07f4c9b708c4a6b45..f15a6e9ac18a4472a480eec40a8139db087ad8f3 100755 (executable)
@@ -278,6 +278,7 @@ qahelp={
        "KEYWORDS.stable":"Ebuilds that have been added directly with stable KEYWORDS",
        "KEYWORDS.stupid":"Ebuilds that use KEYWORDS=-* instead of package.mask", 
        "LICENSE.missing":"Ebuilds that have a missing or empty LICENSE variable",
+       "LICENSE.virtual":"Virtuals that have a non-empty LICENSE variable",
        "DESCRIPTION.missing":"Ebuilds that have a missing or empty DESCRIPTION variable",
        "DESCRIPTION.toolong":"DESCRIPTION is over %d characters" % max_desc_len,
        "EAPI.definition":"EAPI is defined after an inherit call (must be defined before)",
@@ -285,6 +286,7 @@ qahelp={
        "EAPI.unsupported":"Ebuilds that have an unsupported EAPI version (you must upgrade portage)",
        "SLOT.invalid":"Ebuilds that have a missing or invalid SLOT variable value",
        "HOMEPAGE.missing":"Ebuilds that have a missing or empty HOMEPAGE variable",
+       "HOMEPAGE.virtual":"Virtuals that have a non-empty HOMEPAGE variable",
        "DEPEND.bad":"User-visible ebuilds with bad DEPEND settings (matched against *visible* ebuilds)",
        "RDEPEND.bad":"User-visible ebuilds with bad RDEPEND settings (matched against *visible* ebuilds)",
        "PDEPEND.bad":"User-visible ebuilds with bad PDEPEND settings (matched against *visible* ebuilds)",
@@ -360,6 +362,8 @@ qawarnings = set((
 "DEPEND.badmaskedindev","RDEPEND.badmaskedindev","PDEPEND.badmaskedindev",
 "DEPEND.badtilde", "RDEPEND.badtilde", "PDEPEND.badtilde",
 "DESCRIPTION.toolong",
+"HOMEPAGE.virtual",
+"LICENSE.virtual",
 "KEYWORDS.dropped",
 "KEYWORDS.stupid",
 "KEYWORDS.missing",
@@ -1381,6 +1385,13 @@ for x in scanlist:
                                stats[myqakey]=stats[myqakey]+1
                                fails[myqakey].append(x+"/"+y+".ebuild")
 
+               if catdir == "virtual":
+                       for var in ("HOMEPAGE", "LICENSE"):
+                               if myaux.get(var):
+                                       myqakey = var + ".virtual"
+                                       stats[myqakey] = stats[myqakey] + 1
+                                       fails[myqakey].append(relative_path)
+
                # 14 is the length of DESCRIPTION=""
                if len(myaux['DESCRIPTION']) > max_desc_len:
                        stats['DESCRIPTION.toolong'] += 1
index dd318a3f94edc564393ede96a87b4ae1b103fb1f..129ffd00bac4bbedb9c542e251449bba9d63b098 100644 (file)
@@ -119,6 +119,9 @@ Ebuilds that have an unsupported EAPI version (you must upgrade portage)
 .B HOMEPAGE.missing
 Ebuilds that have a missing or empty HOMEPAGE variable
 .TP
+.B HOMEPAGE.virtual
+Virtuals that have a non-empty HOMEPAGE variable
+.TP
 .B IUSE.invalid
 This ebuild has a variable in IUSE that is not in the use.desc or its metadata.xml file
 .TP
@@ -149,6 +152,9 @@ Ebuilds that have a missing or empty LICENSE variable
 .B LICENSE.syntax
 Syntax error in LICENSE (usually an extra/missing space/parenthesis)
 .TP
+.B LICENSE.virtual
+Virtuals that have a non-empty LICENSE variable
+.TP
 .B LIVEVCS.stable
 Ebuild is a live ebuild (cvs, git, darcs, svn, etc) checkout with stable keywords.
 .TP