dev-python/xmlschema: New package
authorMichał Górny <mgorny@gentoo.org>
Thu, 21 Nov 2019 17:03:29 +0000 (18:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 21 Nov 2019 17:25:48 +0000 (18:25 +0100)
New 'xmlschema' package, a test-dep of dev-python/pytest-5.3.0.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/xmlschema/Manifest [new file with mode: 0644]
dev-python/xmlschema/metadata.xml [new file with mode: 0644]
dev-python/xmlschema/xmlschema-1.0.16.ebuild [new file with mode: 0644]

diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
new file mode 100644 (file)
index 0000000..6fded96
--- /dev/null
@@ -0,0 +1 @@
+DIST xmlschema-1.0.16.tar.gz 278082 BLAKE2B 284f71536f86475fbfccefe1130fbea9319282e34ec11a1ca13c6ddd0f8aad2747d66c8cc6443885982c6f98fa074778f2757d012d1380ae46136dc3e5df4a69 SHA512 5dd79e608036995d70b4da627f89c86cd8e7a66f80c2cb87d701395229daa920759769bf7efad34c33dd28ca14971eb155a654f8fec12fb6ace8cb5ecf979650
diff --git a/dev-python/xmlschema/metadata.xml b/dev-python/xmlschema/metadata.xml
new file mode 100644 (file)
index 0000000..266e3f1
--- /dev/null
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/xmlschema/xmlschema-1.0.16.ebuild b/dev-python/xmlschema/xmlschema-1.0.16.ebuild
new file mode 100644 (file)
index 0000000..26c6d0f
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/elementpath[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/lxml[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
+       )"
+
+python_test() {
+       "${EPYTHON}" xmlschema/tests/test_all.py -v ||
+               die "Tests fail with ${EPYTHON}"
+}