www-servers/nginx: add pax-mark for USE=pax-mark
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 13 Apr 2019 03:48:45 +0000 (05:48 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 13 Apr 2019 03:48:45 +0000 (05:48 +0200)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-servers/nginx/nginx-1.14.2-r4.ebuild [moved from www-servers/nginx/nginx-1.14.2-r3.ebuild with 99% similarity]

similarity index 99%
rename from www-servers/nginx/nginx-1.14.2-r3.ebuild
rename to www-servers/nginx/nginx-1.14.2-r4.ebuild
index c7c8f616f3a04333d3883fd34eca54f0e0ed5249..dde537f4fa2429c2df5d25aee411aa9f233b22ab 100644 (file)
@@ -165,7 +165,7 @@ NJS_MODULE_WD="${WORKDIR}/njs-${NJS_MODULE_PV}"
 SSL_DEPS_SKIP=1
 AUTOTOOLS_AUTO_DEPEND="no"
 
-inherit autotools ssl-cert toolchain-funcs perl-module flag-o-matic user systemd versionator multilib
+inherit autotools ssl-cert toolchain-funcs perl-module flag-o-matic user systemd versionator multilib pax-utils
 
 DESCRIPTION="Robust, small and high performance http and reverse proxy server"
 HOMEPAGE="https://nginx.org"
@@ -751,6 +751,10 @@ src_install() {
        insinto /etc/logrotate.d
        newins "${FILESDIR}"/nginx.logrotate-r1 nginx
 
+       if use luajit; then
+               pax-mark m "${ED%/}/usr/sbin/nginx"
+       fi
+
        if use nginx_modules_http_perl; then
                cd "${S}"/objs/src/http/modules/perl/ || die
                emake DESTDIR="${D}" INSTALLDIRS=vendor