app-text/openjade: Allow for compiling with GCC 6
authorDavid Seifert <soap@gentoo.org>
Wed, 14 Sep 2016 22:27:11 +0000 (00:27 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 14 Sep 2016 22:27:32 +0000 (00:27 +0200)
Gentoo-bug: 592590
* Fix overlong DESCRIPTION

Package-Manager: portage-2.3.0

app-text/openjade/openjade-1.3.2-r6.ebuild

index 6f9aba742a7a39442df1a175ddc2bde3ec116927..f6bd9b76f5902037a11c704c4a4a7c7be9c98560 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -6,7 +6,7 @@ EAPI=5
 
 inherit autotools sgml-catalog eutils flag-o-matic multilib
 
-DESCRIPTION="Jade is an implementation of DSSSL - an ISO standard for formatting SGML and XML documents"
+DESCRIPTION="Jade is an implementation of DSSSL for formatting SGML and XML documents"
 HOMEPAGE="http://openjade.sourceforge.net"
 SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
 
@@ -50,6 +50,11 @@ src_prepare() {
 }
 
 src_configure() {
+       # avoids dead-store elimination optimization
+       # leading to segfaults on GCC 6
+       # bug #592590
+       append-cxxflags -fno-lifetime-dse
+
        # We need Prefix env, bug #287358
        export CONFIG_SHELL="${CONFIG_SHELL:-${BASH}}"
        econf \