net-misc/seafile: version bump to 6.2.11
authorDenis Efremov <efremov@linux.com>
Thu, 27 Jun 2019 09:28:05 +0000 (12:28 +0300)
committerMichał Górny <mgorny@gentoo.org>
Mon, 15 Jul 2019 17:24:38 +0000 (19:24 +0200)
Closes: https://bugs.gentoo.org/674638
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Signed-off-by: Denis Efremov <efremov@linux.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-misc/seafile/Manifest
net-misc/seafile/seafile-6.2.11.ebuild [new file with mode: 0644]

index 9887b252bf98e2e30d622d7b996074295bd17410..defc91f96dc7afe9bf951cf2a4cd1356cbb22841 100644 (file)
@@ -1,2 +1,3 @@
 DIST seafile-6.1.7.tar.gz 825734 BLAKE2B 204ede4870f15cbfa9da7e51f565078290b4d03d36a0f8f7a35d54ca1f26c414c350ac05628054d290723b067dfda45aeec1777a2d32e1b376654323106083a4 SHA512 5ae27b2f8e84d57ecd9d81a42fab9611d56a260adb027fba427a700d0d17cd215b3c5b5b37df7e14181bb9ae7df611df9895181de135425ec42da44511d2545e
+DIST seafile-6.2.11.tar.gz 703739 BLAKE2B a072b103875e3a90a9c457079d3101262abc826659c604130f7c3e9d1b129e7d806b687a5673109b37cf040bba02a0a862374997a819cf384ecf2bd3bb6af058 SHA512 90ff1ca4c2a75da9a44d7833209800629c7bec3e8d5b651a820d158261bee77a3b7e599748e6ed350fe919fb67685882a215c18720b0a9702d56e384b8561985
 DIST seafile-6.2.4.tar.gz 705760 BLAKE2B 2fc0d0c370f3a3de11cbee017be3599aa2b099c08de75b23a86a0b586ab83d928d4305f2e2c0571b3b6b1f7de1eaf23a1868febcc3db9e65f08072826a5dd480 SHA512 f9d95990e913ff63835c83d429df6be66f78c993df0c38bb029090a20dfbb4d789e18e679450634f0c6d918c7ff824347301412805b86f797b81719aafa43f9a
diff --git a/net-misc/seafile/seafile-6.2.11.ebuild b/net-misc/seafile/seafile-6.2.11.ebuild
new file mode 100644 (file)
index 0000000..a667cc0
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://github.com/haiwen/seafile/ http://www.seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       net-libs/libsearpc[${PYTHON_USEDEP}]
+       dev-libs/glib:2
+       dev-libs/libevent:0
+       dev-libs/jansson
+       sys-libs/zlib:0
+       net-misc/curl
+       dev-libs/openssl:0
+       dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+       $(vala_depend)"
+
+src_prepare() {
+       default
+       sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+       eautoreconf
+       vala_src_prepare
+}
+
+src_install() {
+       default
+       # Remove unnecessary .la files, as recommended by ltprune.eclass
+       find "${ED}" -name '*.la' -delete || die
+       python_fix_shebang "${ED}"/usr/bin
+}