dev-util/pycharm-community: Version bump (v2020.1.1)
authorMikle Kolyada <zlogene@gentoo.org>
Wed, 13 May 2020 10:31:18 +0000 (13:31 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 13 May 2020 10:31:18 +0000 (13:31 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-util/pycharm-community/Manifest
dev-util/pycharm-community/pycharm-community-2020.1.1.ebuild [new file with mode: 0644]

index 5c266167ada7b599220eedba09c077a4c3ecd523..c88ead0785cb1fda98171fe9a7a47de0c7a7d0e0 100644 (file)
@@ -2,4 +2,5 @@ DIST pycharm-community-2019.3.1.tar.gz 389620376 BLAKE2B a780ab27feef9747539d9cd
 DIST pycharm-community-2019.3.2.tar.gz 391689310 BLAKE2B 11627839e823e2d6c946f5fa25df28cb919960300c51dcc2883989341228604dad9ebf365ffc055809bf3768d757b40cb059a7b5cc492935733c5576ff3f9933 SHA512 6c9e607d938a23be78b4acb5aa39e6276720347aac6fadfbaf456e4f05af4b55ef24f4a97f3aca91b6f09d68af7ec834a5af5e08b775d1439d573cff6c6d3e7c
 DIST pycharm-community-2019.3.3.tar.gz 391606138 BLAKE2B a07bf941ea7a98cadf6ff15b8f69e745ceecf0a820a098811d462a638b0d1b749e1580e23f0cfbdb78a9740e0f41777dd7d505527b6bc83f9c9d5e9ff70a6c95 SHA512 566667109662cffeaba6da9b5e5837adb00f8fbb29523f8415d4fd691cb71f7a40952d28c3713c0409ecbf50ce116ef83bf34a4cbe46015a2a11593771dc97a9
 DIST pycharm-community-2019.3.4.tar.gz 391698063 BLAKE2B f089515412a769c7ffb88cd30aab43def64ff66a0d59ced35740efac4d604220fa5d293d8eb65eea0fc35c116f9d5f771f50f38fc1e61329507cd62070e39ad8 SHA512 0cb5684816eb739de5d106ab8262c9004914d174e89210866286841512c1aa80c00af4299c72f31c1da59c4ed92da10f423c9d5c37e53e1fe836f0586da30c6e
+DIST pycharm-community-2020.1.1.tar.gz 383138867 BLAKE2B 872c658709cab76636f864caff4be4086f861347f5591cf846f6e2b57593380d796a417a684e935b5d3cc6482d80d60f04553e1c11f31fb63554df6a683512ba SHA512 91465d6754981f88a1175ba7da40eb8aed128897b732ba598caa3dbbd6b928f56857c0e80c7bc6c27bb276ffa9a5529dbdcd4508ea1b038579bc7bf359d83ab4
 DIST pycharm-community-2020.1.tar.gz 382333125 BLAKE2B 5fa9000bad467784f2276286639c98509481ab3aef7482f8d0d166d058b2798fb027c037762c76dfd947376320e75f05045b34f172f849198c63950fe27d9855 SHA512 7e2663ac21536f7663910d0e2561a93869f46cc7b1d06bbc448d5afbdf89c4fcb834b9e7e3f61263e5c0a3d25caf35c663a42c6219ae2d5a67cb2516eba2e8e6
diff --git a/dev-util/pycharm-community/pycharm-community-2020.1.1.ebuild b/dev-util/pycharm-community/pycharm-community-2020.1.1.ebuild
new file mode 100644 (file)
index 0000000..f8be402
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bundled-jdk"
+
+RDEPEND="!bundled-jdk? ( >=virtual/jre-1.8 )
+       dev-libs/libdbusmenu
+       dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+       opt/${PN}/bin/fsnotifier64
+       opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_install() {
+       insinto /opt/${PN}
+       doins -r *
+
+       if use bundled-jdk; then
+               fperms -R a+x /opt/pycharm-community/jbr/bin/
+       else
+               rm -r "${D}"/opt/pycharm-community/jbr/ || die
+       fi
+
+       fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+       dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+       newicon bin/${MY_PN}.png ${PN}.png
+       make_desktop_entry ${PN} ${PN} ${PN}
+
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_icon_cache_update
+}