media-sound/split2flac: Update live ebuild
authorDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 15:21:23 +0000 (17:21 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 15:21:23 +0000 (17:21 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/split2flac/split2flac-9999.ebuild

index fd0a7bea899843f8b1add82cf245e2760f51e3a8..762b68edc49830f9dac0d2c75acc78f6d93bed27 100644 (file)
@@ -1,22 +1,23 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
-
-EGIT_REPO_URI="https://github.com/ftrvxmtrx/split2flac.git"
+EAPI=7
 
 inherit bash-completion-r1
-[[ ${PV} == *9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ftrvxmtrx/split2flac.git"
+else
+       SRC_URI="https://github.com/ftrvxmtrx/split2flac/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
 
 DESCRIPTION="sh script to split an APE/FLAC/WV/WAV audio image with CUE sheet into tracks"
 HOMEPAGE="https://github.com/ftrvxmtrx/split2flac"
-[[ ${PV} == *9999* ]] || \
-SRC_URI="https://rion-overlay.googlecode.com/files/${P}.tar.xz"
 
 LICENSE="MIT"
 SLOT="0"
-[[ ${PV} == *9999* ]] || \
-KEYWORDS="~amd64 ~x86"
 IUSE="enca flake imagemagick mac mp3 mp4 ogg replaygain wavpack"
 
 RDEPEND="
@@ -34,20 +35,18 @@ RDEPEND="
                mp3? ( media-sound/mp3gain )
                ogg? ( media-sound/vorbisgain )
        )
-       imagemagick? ( media-gfx/imagemagick )
-"
-
-src_configure() { :; }
-
-src_compile() { :; }
+       imagemagick? ( media-gfx/imagemagick )"
 
 src_install() {
        dobin ${PN}
        newbashcomp ${PN}-bash-completion.sh ${PN}
 
        dosym ${PN} /usr/bin/split2wav
-       for i in mp3 mp4 ogg
-       do
+
+       local i
+       for i in mp3 mp4 ogg; do
                use $i && dosym ${PN} /usr/bin/split2${i/mp4/m4a}
        done
+
+       einstalldocs
 }