dev-ros/test_rospy: upstream py3 fixes
authorAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 13:57:15 +0000 (14:57 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 14:46:59 +0000 (15:46 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/test_rospy/files/py3-2.patch [new file with mode: 0644]
dev-ros/test_rospy/files/py3.patch [new file with mode: 0644]
dev-ros/test_rospy/test_rospy-1.14.3-r1.ebuild [moved from dev-ros/test_rospy/test_rospy-1.14.3.ebuild with 89% similarity]

diff --git a/dev-ros/test_rospy/files/py3-2.patch b/dev-ros/test_rospy/files/py3-2.patch
new file mode 100644 (file)
index 0000000..18ac23d
--- /dev/null
@@ -0,0 +1,40 @@
+From 1933acfa8107a164ec825d3223d14589fefd1b5b Mon Sep 17 00:00:00 2001
+From: Dirk Thomas <dirk-thomas@users.noreply.github.com>
+Date: Tue, 6 Aug 2019 16:06:51 -0700
+Subject: [PATCH] more Python 3 compatibility (#1783)
+
+---
+ test/test_rospy/test/unit/test_genmsg_py.py   |  6 +--
+ tools/rosgraph/src/rosgraph/roslogging.py     |  2 +-
+ .../test/test_roslogging_user_logger.py       |  8 +++-
+ tools/roslaunch/test/unit/test_xmlloader.py   |  2 +-
+ tools/rosmsg/src/rosmsg/__init__.py           |  2 +-
+ tools/rosmsg/test/test_rosmsg_command_line.py | 46 +++++++++----------
+ .../test/test_rosmsgproto_command_line.py     | 20 ++++----
+ .../test_rostopic_command_line_offline.py     | 44 +++++++++---------
+ 8 files changed, 67 insertions(+), 63 deletions(-)
+
+diff --git a/test/test_rospy/test/unit/test_genmsg_py.py b/test/test_rospy/test/unit/test_genmsg_py.py
+index 397b35cee..38be1648e 100644
+--- a/test/test_rospy/test/unit/test_genmsg_py.py
++++ b/test/test_rospy/test/unit/test_genmsg_py.py
+@@ -95,8 +95,8 @@ def test_test_rospy_TestFixedArray(self):
+         self.assertEquals([0., 0., 0.], m.f64_3)        
+         self.assertEquals([0], m.i8_1)
+         self.assertEquals([0, 0, 0], m.i8_3)        
+-        self.assertEquals(chr(0), m.u8_1)
+-        self.assertEquals(chr(0)*3, m.u8_3)        
++        self.assertEquals(chr(0).encode(), m.u8_1)
++        self.assertEquals((chr(0)*3).encode(), m.u8_3)
+         self.assertEquals([0], m.i32_1)
+         self.assertEquals([0, 0, 0], m.i32_3)        
+         self.assertEquals([0], m.u32_1)
+@@ -358,7 +358,7 @@ def test_std_msgs_MultiArray(self):
+         # test. the buff was with the uint8[] type consistency
+         buff = StringIO()
+         self.assertEquals(UInt8MultiArray(),UInt8MultiArray())
+-        self.assertEquals('',UInt8MultiArray().data)        
++        self.assertEquals(b'', UInt8MultiArray().data)
+         UInt8MultiArray().serialize(buff)
+         self.assertEquals(UInt8MultiArray(layout=MultiArrayLayout()),UInt8MultiArray())
+         UInt8MultiArray(layout=MultiArrayLayout()).serialize(buff)
diff --git a/dev-ros/test_rospy/files/py3.patch b/dev-ros/test_rospy/files/py3.patch
new file mode 100644 (file)
index 0000000..d7ed0f9
--- /dev/null
@@ -0,0 +1,34 @@
+From 8f22c20e418abe4abe23e789eef517a16a50604d Mon Sep 17 00:00:00 2001
+From: Dirk Thomas <dirk-thomas@users.noreply.github.com>
+Date: Tue, 6 Aug 2019 12:50:24 -0700
+Subject: [PATCH] more Python 3 compatibility (#1782)
+
+---
+ test/test_rosmaster/test/nodes/testAllCommonFlows  | 2 +-
+ test/test_rosmaster/test/nodes/testMaster          | 2 +-
+ test/test_rosmaster/test/nodes/testSlave           | 2 +-
+ test/test_rospy/test/unit/test_genmsg_py.py        | 8 +++++++-
+ tools/rosgraph/test/test_roslogging.py             | 5 ++++-
+ tools/rosgraph/test/test_roslogging_user_logger.py | 5 ++++-
+ tools/roslaunch/src/roslaunch/depends.py           | 8 ++++----
+ 7 files changed, 22 insertions(+), 10 deletions(-)
+
+diff --git a/test/test_rospy/test/unit/test_genmsg_py.py b/test/test_rospy/test/unit/test_genmsg_py.py
+index aebf95b22..397b35cee 100644
+--- a/test/test_rospy/test/unit/test_genmsg_py.py
++++ b/test/test_rospy/test/unit/test_genmsg_py.py
+@@ -44,7 +44,13 @@
+ import math
+ from roslib.message import SerializationError
+-        
++
++try:
++    long
++except NameError:
++    long = int
++
++
+ class TestGenmsgPy(unittest.TestCase):
+     def test_PythonKeyword(self):
similarity index 89%
rename from dev-ros/test_rospy/test_rospy-1.14.3.ebuild
rename to dev-ros/test_rospy/test_rospy-1.14.3-r1.ebuild
index c681d244b919a69d79068480966a1e202eef330a..2cf6f27175538f9b8568ef9bb5be8b251785487f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -31,3 +31,4 @@ DEPEND="${RDEPEND}
                dev-ros/rospy[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
        )"
+PATCHES=( "${FILESDIR}/py3.patch" "${FILESDIR}/py3-2.patch" )