*/*: Switch Perlovka's ebuilds to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 11 Jan 2020 23:44:17 +0000 (00:44 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 11 Jan 2020 23:51:30 +0000 (00:51 +0100)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
14 files changed:
dev-libs/libarcus/libarcus-4.2.0.ebuild
dev-libs/libarcus/libarcus-4.3.0.ebuild
dev-libs/libcharon/libcharon-4.2.0.ebuild
dev-libs/libcharon/libcharon-4.3.0.ebuild
dev-libs/libsavitar/libsavitar-4.2.0.ebuild
dev-libs/libsavitar/libsavitar-4.3.0.ebuild
dev-python/uranium/uranium-4.2.0.ebuild
dev-python/uranium/uranium-4.3.0.ebuild
media-gfx/cura/cura-4.2.1.ebuild
media-gfx/cura/cura-4.3.0.ebuild
media-gfx/curaengine/curaengine-4.2.0.ebuild
media-gfx/curaengine/curaengine-4.3.0.ebuild
media-gfx/fdm-materials/fdm-materials-4.2.0.ebuild
media-gfx/fdm-materials/fdm-materials-4.3.0.ebuild

index 1c7ede9b949ce5108e222a175c89cb8491cca592..deb2605d56493bf84e1356e2d8d1fe414825bc85 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
 
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 MY_PN="libArcus"
 
@@ -38,5 +38,5 @@ src_configure() {
                -DBUILD_STATIC=$(usex static-libs ON OFF)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index a021b6d2dfa110e88a3fad776cc6108eea1e49cc..0869769e8f5b59b8b668c04c1451fb7ea75ba286 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
 
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 MY_PN="libArcus"
 
@@ -38,7 +38,7 @@ src_prepare() {
        sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" CMakeLists.txt || die
        sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" cmake/FindSIP.cmake || die
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -48,5 +48,5 @@ src_configure() {
                -DBUILD_STATIC=$(usex static-libs ON OFF)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index 1d3eec7064d6c0c4108f9e82be4a1c553b73d3d9..f216952ac7f43c0372c4f8e666d01f9c05265cfc 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 MY_PN="libCharon"
 
index 4b4f9516eddc6df941efa514c0a3168e8587b276..cf5a18458b037a4d0f9b741c061d01ce2fc8a93c 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 MY_PN="libCharon"
 
@@ -26,5 +26,5 @@ src_prepare() {
        # Use current python version, not the latest installed
        sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" CMakeLists.txt || die
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
index 4c15ddaee247d76e241e0eee261054485b0711f9..26c10c69fca2c665fbf865c7532e9b356aada9b2 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 MY_PN="libSavitar"
 
@@ -38,5 +38,5 @@ src_configure() {
                -DBUILD_STATIC=$(usex static-libs ON OFF)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index 4ddf5a3e942d2f1f6b0ec690fdc13306069b912f..1b2ed0ae3c2bda5c1dfd851c28ebffcf2dc31854 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 MY_PN="libSavitar"
 
@@ -37,7 +37,7 @@ src_prepare() {
        sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" CMakeLists.txt || die
        sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" cmake/FindSIP.cmake || die
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -46,5 +46,5 @@ src_configure() {
                -DBUILD_STATIC=$(usex static-libs ON OFF)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index 2b2c66367c388c0c0c688c62fa6dc4db18d98fd4..8b3f307a109cc93df04f357c8f4954cf4068bc0b 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
 
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 MY_PN="Uranium"
 
@@ -17,9 +17,10 @@ LICENSE="LGPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="debug doc test"
-RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
+RESTRICT="!test? ( test )"
+
 BDEPEND="${PYTHON_DEPS}
        sys-devel/gettext
        doc? ( app-doc/doxygen )
@@ -44,8 +45,9 @@ S="${WORKDIR}/${MY_PN}-${PV}"
 
 src_configure() {
        local mycmakeargs=(
-               -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
-       cmake-utils_src_configure
+               -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
+       )
+       cmake_src_configure
 
        if ! use debug; then
                sed -i 's/logging.DEBUG/logging.ERROR/' plugins/ConsoleLogger/ConsoleLogger.py || die
@@ -54,14 +56,14 @@ src_configure() {
 }
 
 src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
        if use doc; then
-               cmake-utils_src_compile doc
+               cmake_src_compile doc
                DOCS+=( html )
        fi
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        python_optimize "${D}/usr/$(get_libdir)"
 }
index e0867d59d2f8a3d8cbc56f5682b03624800b2c86..4ca593a01581a144ddf55ea27ba12ffc99c436ad 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
 
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 MY_PN="Uranium"
 
@@ -17,9 +17,10 @@ LICENSE="LGPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="debug doc test"
-RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
+RESTRICT="!test? ( test )"
+
 BDEPEND="${PYTHON_DEPS}
        sys-devel/gettext
        doc? ( app-doc/doxygen )
@@ -47,8 +48,9 @@ S="${WORKDIR}/${MY_PN}-${PV}"
 
 src_configure() {
        local mycmakeargs=(
-               -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
-       cmake-utils_src_configure
+               -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
+       )
+       cmake_src_configure
 
        if ! use debug; then
                sed -i 's/logging.DEBUG/logging.ERROR/' plugins/ConsoleLogger/ConsoleLogger.py || die
@@ -57,14 +59,14 @@ src_configure() {
 }
 
 src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
        if use doc; then
-               cmake-utils_src_compile doc
+               cmake_src_compile doc
                DOCS+=( html )
        fi
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        python_optimize "${D}/usr/$(get_libdir)"
 }
index 5068f8f59f738539ecfac8d5a376ab6eaed258cd..ba1e9563f25ed0bf583ff6a1943f45b2da292e2f 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
-inherit cmake-utils desktop python-single-r1 xdg
+inherit cmake desktop python-single-r1 xdg
 
 MY_PN=Cura
 
@@ -36,18 +36,18 @@ S="${WORKDIR}/${MY_PN}-${PV}"
 
 src_prepare() {
        sed -i "s/set(CURA_VERSION \"master\"/set(CURA_VERSION \"${PV}\"/" CMakeLists.txt || die
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
        local mycmakeargs=(
                -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        doicon icons/*.png
        python_optimize "${D}${get_libdir}"
 }
index 5068f8f59f738539ecfac8d5a376ab6eaed258cd..ba1e9563f25ed0bf583ff6a1943f45b2da292e2f 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
-inherit cmake-utils desktop python-single-r1 xdg
+inherit cmake desktop python-single-r1 xdg
 
 MY_PN=Cura
 
@@ -36,18 +36,18 @@ S="${WORKDIR}/${MY_PN}-${PV}"
 
 src_prepare() {
        sed -i "s/set(CURA_VERSION \"master\"/set(CURA_VERSION \"${PV}\"/" CMakeLists.txt || die
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
        local mycmakeargs=(
                -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        doicon icons/*.png
        python_optimize "${D}${get_libdir}"
 }
index 8fc2576a3f8fcd3debcca6aeee1409fc5cf7546a..775c51f9f0765f8f6bd9d0c3cce9a05130bc8e6a 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils toolchain-funcs
+inherit cmake toolchain-funcs
 
 MY_PN="CuraEngine"
 
@@ -45,11 +45,11 @@ pkg_pretend() {
 
 src_configure() {
        local mycmakeargs=( "-DBUILD_TESTS=$(usex test ON OFF)" )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_compile() {
-       cmake-utils_src_make
+       cmake_build
        if use doc; then
                doxygen
                mv docs/html . || die
index b2a9c9017ef2b2d347f4bc6125b7c0fdf336fa37..3e767bdc29bacd04bef2ed17e7ac28fb72335640 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils toolchain-funcs
+inherit cmake toolchain-funcs
 
 MY_PN="CuraEngine"
 
@@ -31,11 +31,11 @@ S="${WORKDIR}/${MY_PN}-${PV}"
 
 src_configure() {
        local mycmakeargs=( "-DBUILD_TESTS=$(usex test ON OFF)" )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_compile() {
-       cmake-utils_src_make
+       cmake_build
        if use doc; then
                doxygen || die
                mv docs/html . || die
index e2cea43f6d83d5931c99e53df801aa7b842568fe..54cf788eca5336e641e16339f695fb88e6ac9816 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 MY_PN="fdm_materials"
 
index e2cea43f6d83d5931c99e53df801aa7b842568fe..54cf788eca5336e641e16339f695fb88e6ac9816 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 MY_PN="fdm_materials"