media-libs/cogl: add missing mesa[egl] dep for USE=kms
authorMart Raudsepp <leio@gentoo.org>
Sun, 17 Nov 2019 17:50:53 +0000 (19:50 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 17 Nov 2019 17:51:21 +0000 (19:51 +0200)
If any EGL platform is enabled, it requires the EGL headers.
This includes kms-egl-platform, which also sets NEED_EGL in
configure.ac.
Remove rm -f option usage while here (it makes the `|| die`
useless and makes us not notice once this call isn't necessary
anymore).

Closes: https://bugs.gentoo.org/613728
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-libs/cogl/cogl-1.22.4.ebuild

index 2191b69cd4aad63aa443ee9e3281faee2474ffa8..12bd445b80ff469b31b90d4cb11f319009a9fcc6 100644 (file)
@@ -36,7 +36,7 @@ COMMON_DEPEND="
                media-libs/gst-plugins-base:1.0 )
        introspection? ( >=dev-libs/gobject-introspection-1.34.2:= )
        kms? (
-               media-libs/mesa[gbm]
+               media-libs/mesa[egl,gbm]
                x11-libs/libdrm:= )
        pango? ( >=x11-libs/pango-1.20.0[introspection?] )
        wayland? (
@@ -114,5 +114,5 @@ src_install() {
        gnome2_src_install
 
        # Remove silly examples-data directory
-       rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+       rm -rv "${ED}/usr/share/cogl/examples-data/" || die
 }