acct-user/steamcmd: add user for games-server/steamcmd (489)
authorConrad Kostecki <conrad@kostecki.com>
Tue, 17 Sep 2019 18:11:24 +0000 (20:11 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 12 Oct 2019 09:09:14 +0000 (12:09 +0300)
UID 489 will be used, as its the next available.
Arch, Fedora and RHEL don't have a UID for the user.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
acct-user/steamcmd/metadata.xml [new file with mode: 0644]
acct-user/steamcmd/steamcmd-0.ebuild [new file with mode: 0644]

diff --git a/acct-user/steamcmd/metadata.xml b/acct-user/steamcmd/metadata.xml
new file mode 100644 (file)
index 0000000..54d5423
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>ck+gentoo@bl4ckb0x.de</email>
+               <name>Conrad Kostecki</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/acct-user/steamcmd/steamcmd-0.ebuild b/acct-user/steamcmd/steamcmd-0.ebuild
new file mode 100644 (file)
index 0000000..bd63596
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="A user for the SteamCMD server"
+
+ACCT_USER_GROUPS=( "steamcmd" )
+ACCT_USER_HOME="/opt/steamcmd"
+ACCT_USER_ID="489"
+
+acct-user_add_deps