sys-apps/systemd: Bump to 225
authorMike Gilbert <floppym@gentoo.org>
Sat, 29 Aug 2015 13:33:10 +0000 (09:33 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 29 Aug 2015 13:33:10 +0000 (09:33 -0400)
Package-Manager: portage-2.2.20

sys-apps/systemd/Manifest
sys-apps/systemd/systemd-225.ebuild [new file with mode: 0644]

index d0ae4b4230ccb6eb4789b506a3ad439475f40f11..063c12c3597fde37806112ae168c78e0a6ba20b7 100644 (file)
@@ -1,4 +1,5 @@
 DIST systemd-218.tar.xz 3782276 SHA256 1b0768b53b6c6d813a93a4b8fe1f80cf53561b09075010a97c7aa08eee3fd59b SHA512 c183cce8532ccb4716b84587c96a626eea390202a5469b9d89c8cee7f703e40d7c584e05f29501d375b8cd2a1409d011de564df16f54e27f66b3c3007a6e5bd4 WHIRLPOOL 4d0bcf3ddfecd3354d9f4ab13851f8da6baf31e89e64d3b1ac671159f16f23597d88cc2525aece2f867c140fc97e80bce086a5af91f84b8095e2503c13995e6d
 DIST systemd-219_p112.tar.xz 3944604 SHA256 8394ca0d55b05cb07c2187da8b614f3cb4eacc297c501dd09a31dad18acf28ea SHA512 480526ff45a8588b3a572ccc455d6357208093f5dae858947182f6e9e4595c1f612d1b661eff41f39f5df6ad0dcb6b0a08b08c15125baf1cf07402ac18a5130b WHIRLPOOL cf1ea60dc59a2a3f54cb66d24a529b742bd403f996a9e8f132fd9f9dc551308ee233fec4fec3e8feb7a657ccdd25e56a6e0756633a1c76a9c427588b262558d9
 DIST systemd-224.tar.gz 3868075 SHA256 0d7ac1532a57639fbc828f8a5051a090883c6ad2908618a7a13ab386db831bfc SHA512 7717d340c6de11afd589234b7ec8952fe2ffcd05829622bd7ea8e008870c0e3b83eb1eaf20e85ffffa7adafc9c0c0b94fd93784510792109240e22e6b963f198 WHIRLPOOL 645b08ff0c20994b17b8ed585fb0eef682336961d7fedf25031fa4dc89a4d9a2b58c254e0f9baeedcb228435316fdfb562f9fefd21e5a63f94499d2f1040e093
+DIST systemd-225.tar.gz 3878442 SHA256 b2f576bb3688e9315f2f49b98e141ac6f964567370e98ebd8fd7332a0a6f9701 SHA512 35b3946509c7b01660da4370d3c51ff0e6a537dadd9dbb0a039c4f7ed552fd4e02ebac6eb8a788f61f1e3ba99444238d959051dd004c174b027729a80368ac19 WHIRLPOOL 47cd3b5690dafdf3c0ef6a9767e947666b1853541f8aefd17eb5c07eee1477daf32f3b249b04327b1c56d8ec430745725383750b97755bb6cf594d354a7ffdf8
 DIST systemd.conf.m4-v219 1493 SHA256 90ee489b6e34945e5cda27a269e1247644382084f5a145a2df691282007c6768 SHA512 a117c40229af3ba2a0cec4c3db01728c3cab49bb6403fc84cb34f8a09979d98f7a200cd28bf2bbc7a71cbad856edf31190fba30a9d5810c55911746457bbf31a WHIRLPOOL a1604a4fdf5e2d4a4505252859c64d0a3c131b4bb371cff8c75331438f291f138d2732d939947988ab95b040e377412db84fbf6c45866fee028a2aac70e8eb9f
diff --git a/sys-apps/systemd/systemd-225.ebuild b/sys-apps/systemd/systemd-225.ebuild
new file mode 100644 (file)
index 0000000..a7df264
--- /dev/null
@@ -0,0 +1,476 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+if [[ ${PV} == 9999 ]]; then
+       EGIT_REPO_URI="https://github.com/systemd/systemd.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~ia64 ~x86"
+fi
+
+inherit autotools-utils bash-completion-r1 linux-info multilib \
+       multilib-minimal pam systemd toolchain-funcs udev user
+
+DESCRIPTION="System and service manager for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+
+LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
+SLOT="0/2"
+IUSE="acl apparmor audit cryptsetup curl elfutils gcrypt gnuefi http
+       idn importd +kdbus +kmod +lz4 lzma nat pam policykit
+       qrcode +seccomp selinux ssl sysv-utils test vanilla xkb"
+
+REQUIRED_USE="importd? ( curl gcrypt lzma )"
+
+MINKV="3.8"
+
+COMMON_DEPEND=">=sys-apps/util-linux-2.26:0=[${MULTILIB_USEDEP}]
+       sys-libs/libcap:0=[${MULTILIB_USEDEP}]
+       !<sys-libs/glibc-2.16
+       acl? ( sys-apps/acl:0= )
+       apparmor? ( sys-libs/libapparmor:0= )
+       audit? ( >=sys-process/audit-2:0= )
+       cryptsetup? ( >=sys-fs/cryptsetup-1.6:0= )
+       curl? ( net-misc/curl:0= )
+       elfutils? ( >=dev-libs/elfutils-0.158:0= )
+       gcrypt? ( >=dev-libs/libgcrypt-1.4.5:0=[${MULTILIB_USEDEP}] )
+       http? (
+               >=net-libs/libmicrohttpd-0.9.33:0=
+               ssl? ( >=net-libs/gnutls-3.1.4:0= )
+       )
+       idn? ( net-dns/libidn:0= )
+       importd? (
+               app-arch/bzip2:0=
+               sys-libs/zlib:0=
+       )
+       kmod? ( >=sys-apps/kmod-15:0= )
+       lz4? ( >=app-arch/lz4-0_p119:0=[${MULTILIB_USEDEP}] )
+       lzma? ( >=app-arch/xz-utils-5.0.5-r1:0=[${MULTILIB_USEDEP}] )
+       nat? ( net-firewall/iptables:0= )
+       pam? ( virtual/pam:= )
+       qrcode? ( media-gfx/qrencode:0= )
+       seccomp? ( sys-libs/libseccomp:0= )
+       selinux? ( sys-libs/libselinux:0= )
+       sysv-utils? (
+               !sys-apps/systemd-sysv-utils
+               !sys-apps/sysvinit )
+       xkb? ( >=x11-libs/libxkbcommon-0.4.1:0= )
+       abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r9
+               !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
+
+# baselayout-2.2 has /run
+RDEPEND="${COMMON_DEPEND}
+       >=sys-apps/baselayout-2.2
+       !sys-auth/nss-myhostname
+       !sys-fs/eudev
+       !sys-fs/udev"
+
+# sys-apps/dbus: the daemon only (+ build-time lib dep for tests)
+PDEPEND=">=sys-apps/dbus-1.6.8-r1:0[systemd]
+       >=sys-apps/hwids-20150417[udev]
+       >=sys-fs/udev-init-scripts-25
+       policykit? ( sys-auth/polkit )
+       !vanilla? ( sys-apps/gentoo-systemd-integration )"
+
+# Newer linux-headers needed by ia64, bug #480218
+DEPEND="${COMMON_DEPEND}
+       app-arch/xz-utils:0
+       dev-util/gperf
+       >=dev-util/intltool-0.50
+       >=sys-apps/coreutils-8.16
+       >=sys-devel/binutils-2.23.1
+       >=sys-devel/gcc-4.6
+       >=sys-kernel/linux-headers-${MINKV}
+       ia64? ( >=sys-kernel/linux-headers-3.9 )
+       virtual/pkgconfig
+       gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
+       test? ( >=sys-apps/dbus-1.6.8-r1:0 )"
+
+if [[ -n ${AUTOTOOLS_AUTORECONF} ]]; then
+       DEPEND+="
+               app-text/docbook-xml-dtd:4.2
+               app-text/docbook-xml-dtd:4.5
+               app-text/docbook-xsl-stylesheets
+               dev-libs/libxslt:0
+               >=dev-libs/libgcrypt-1.4.5:0"
+fi
+
+PATCHES=( "${FILESDIR}/218-Dont-enable-audit-by-default.patch" )
+
+pkg_pretend() {
+       local CONFIG_CHECK="~AUTOFS4_FS ~BLK_DEV_BSG ~CGROUPS
+               ~DEVPTS_MULTIPLE_INSTANCES ~DEVTMPFS ~DMIID ~EPOLL ~FANOTIFY ~FHANDLE
+               ~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SECCOMP ~SIGNALFD ~SYSFS
+               ~TIMERFD ~TMPFS_XATTR
+               ~!FW_LOADER_USER_HELPER ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
+               ~!SYSFS_DEPRECATED_V2"
+
+       use acl && CONFIG_CHECK+=" ~TMPFS_POSIX_ACL"
+       kernel_is -lt 3 7 && CONFIG_CHECK+=" ~HOTPLUG"
+
+       if linux_config_exists; then
+               local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)
+                       if [ -n "${uevent_helper_path}" ] && [ "${uevent_helper_path}" != '""' ]; then
+                               ewarn "It's recommended to set an empty value to the following kernel config option:"
+                               ewarn "CONFIG_UEVENT_HELPER_PATH=${uevent_helper_path}"
+                       fi
+       fi
+
+       if [[ ${MERGE_TYPE} != binary ]]; then
+               if [[ $(gcc-major-version) -lt 4
+                       || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ) ]]
+               then
+                       eerror "systemd requires at least gcc 4.6 to build. Please switch the active"
+                       eerror "gcc version using gcc-config."
+                       die "systemd requires at least gcc 4.6"
+               fi
+       fi
+
+       if [[ ${MERGE_TYPE} != buildonly ]]; then
+               if kernel_is -lt ${MINKV//./ }; then
+                       ewarn "Kernel version at least ${MINKV} required"
+               fi
+
+               check_extra_config
+       fi
+}
+
+pkg_setup() {
+       :
+}
+
+src_unpack() {
+       default
+       [[ ${PV} != 9999 ]] || git-r3_src_unpack
+}
+
+src_prepare() {
+       # Bug 463376
+       sed -i -e 's/GROUP="dialout"/GROUP="uucp"/' rules/*.rules || die
+
+       autotools-utils_src_prepare
+}
+
+src_configure() {
+       # Keep using the one where the rules were installed.
+       MY_UDEVDIR=$(get_udevdir)
+       # Fix systems broken by bug #509454.
+       [[ ${MY_UDEVDIR} ]] || MY_UDEVDIR=/lib/udev
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               # disable -flto since it is an optimization flag
+               # and makes distcc less effective
+               cc_cv_CFLAGS__flto=no
+
+               # Workaround for gcc-4.7, bug 554454.
+               cc_cv_CFLAGS__Werror_shadow=no
+
+               # Workaround for bug 516346
+               --enable-dependency-tracking
+
+               --disable-maintainer-mode
+               --localstatedir=/var
+               --with-pamlibdir=$(getpam_mod_dir)
+               # avoid bash-completion dep
+               --with-bashcompletiondir="$(get_bashcompdir)"
+               # make sure we get /bin:/sbin in $PATH
+               --enable-split-usr
+               # For testing.
+               --with-rootprefix="${ROOTPREFIX-/usr}"
+               --with-rootlibdir="${ROOTPREFIX-/usr}/$(get_libdir)"
+               # disable sysv compatibility
+               --with-sysvinit-path=
+               --with-sysvrcnd-path=
+               # no deps
+               --enable-efi
+               --enable-ima
+               --without-python
+
+               # Optional components/dependencies
+               $(multilib_native_use_enable acl)
+               $(multilib_native_use_enable apparmor)
+               $(multilib_native_use_enable audit)
+               $(multilib_native_use_enable cryptsetup libcryptsetup)
+               $(multilib_native_use_enable curl libcurl)
+               $(multilib_native_use_enable elfutils)
+               $(use_enable gcrypt)
+               $(multilib_native_use_enable gnuefi)
+               $(multilib_native_use_enable http microhttpd)
+               $(usex http $(multilib_native_use_enable ssl gnutls) --disable-gnutls)
+               $(multilib_native_use_enable idn libidn)
+               $(multilib_native_use_enable importd)
+               $(multilib_native_use_enable importd bzip2)
+               $(multilib_native_use_enable importd zlib)
+               $(use_enable kdbus)
+               $(multilib_native_use_enable kmod)
+               $(use_enable lz4)
+               $(use_enable lzma xz)
+               $(multilib_native_use_enable nat libiptc)
+               $(multilib_native_use_enable pam)
+               $(multilib_native_use_enable policykit polkit)
+               $(multilib_native_use_enable qrcode qrencode)
+               $(multilib_native_use_enable seccomp)
+               $(multilib_native_use_enable selinux)
+               $(multilib_native_use_enable test tests)
+               $(multilib_native_use_enable test dbus)
+               $(multilib_native_use_enable xkb xkbcommon)
+
+               # hardcode a few paths to spare some deps
+               QUOTAON=/usr/sbin/quotaon
+               QUOTACHECK=/usr/sbin/quotacheck
+
+               # TODO: we may need to restrict this to gcc
+               EFI_CC="$(tc-getCC)"
+
+               # dbus paths
+               --with-dbuspolicydir="${EPREFIX}/etc/dbus-1/system.d"
+               --with-dbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+               --with-dbussystemservicedir="${EPREFIX}/usr/share/dbus-1/system-services"
+
+               --with-ntp-servers="0.gentoo.pool.ntp.org 1.gentoo.pool.ntp.org 2.gentoo.pool.ntp.org 3.gentoo.pool.ntp.org"
+       )
+
+       # Work around bug 463846.
+       tc-export CC
+
+       autotools-utils_src_configure
+}
+
+multilib_src_compile() {
+       local mymakeopts=(
+               udevlibexecdir="${MY_UDEVDIR}"
+       )
+
+       if multilib_is_native_abi; then
+               emake "${mymakeopts[@]}"
+       else
+               echo 'gentoo: $(BUILT_SOURCES)' | \
+               emake "${mymakeopts[@]}" -f Makefile -f - gentoo
+               echo 'gentoo: $(lib_LTLIBRARIES) $(pkgconfiglib_DATA)' | \
+               emake "${mymakeopts[@]}" -f Makefile -f - gentoo
+       fi
+}
+
+multilib_src_test() {
+       multilib_is_native_abi || continue
+
+       default
+}
+
+multilib_src_install() {
+       local mymakeopts=(
+               # automake fails with parallel libtool relinking
+               # https://bugs.gentoo.org/show_bug.cgi?id=491398
+               -j1
+
+               udevlibexecdir="${MY_UDEVDIR}"
+               dist_udevhwdb_DATA=
+               DESTDIR="${D}"
+       )
+
+       if multilib_is_native_abi; then
+               emake "${mymakeopts[@]}" install
+       else
+               mymakeopts+=(
+                       install-libLTLIBRARIES
+                       install-pkgconfiglibDATA
+                       install-includeHEADERS
+                       # safe to call unconditionally, 'installs' empty list
+                       install-pkgincludeHEADERS
+               )
+
+               emake "${mymakeopts[@]}"
+       fi
+
+       # install compat pkg-config files
+       # Change dbus to >=sys-apps/dbus-1.8.8 if/when this is dropped.
+       local pcfiles=( src/compat-libs/libsystemd-{daemon,id128,journal,login}.pc )
+       emake "${mymakeopts[@]}" install-pkgconfiglibDATA \
+               pkgconfiglib_DATA="${pcfiles[*]}"
+}
+
+multilib_src_install_all() {
+       prune_libtool_files --modules
+       einstalldocs
+
+       if use sysv-utils; then
+               for app in halt poweroff reboot runlevel shutdown telinit; do
+                       dosym "..${ROOTPREFIX-/usr}/bin/systemctl" /sbin/${app}
+               done
+               dosym "..${ROOTPREFIX-/usr}/lib/systemd/systemd" /sbin/init
+       else
+               # we just keep sysvinit tools, so no need for the mans
+               rm "${D}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
+                       || die
+               rm "${D}"/usr/share/man/man1/init.1 || die
+       fi
+
+       # Disable storing coredumps in journald, bug #433457
+       mv "${D}"/usr/lib/sysctl.d/50-coredump.conf{,.disabled} || die
+
+       # Preserve empty dirs in /etc & /var, bug #437008
+       keepdir /etc/binfmt.d /etc/modules-load.d /etc/tmpfiles.d \
+               /etc/systemd/ntp-units.d /etc/systemd/user /var/lib/systemd \
+               /var/log/journal/remote
+
+       # Symlink /etc/sysctl.conf for easy migration.
+       dosym ../sysctl.conf /etc/sysctl.d/99-sysctl.conf
+
+       # If we install these symlinks, there is no way for the sysadmin to remove them
+       # permanently.
+       rm "${D}"/etc/systemd/system/multi-user.target.wants/systemd-networkd.service || die
+       rm "${D}"/etc/systemd/system/multi-user.target.wants/systemd-resolved.service || die
+       rm -r "${D}"/etc/systemd/system/network-online.target.wants || die
+       rm -r "${D}"/etc/systemd/system/sockets.target.wants || die
+       rm -r "${D}"/etc/systemd/system/sysinit.target.wants || die
+}
+
+migrate_locale() {
+       local envd_locale_def="${EROOT%/}/etc/env.d/02locale"
+       local envd_locale=( "${EROOT%/}"/etc/env.d/??locale )
+       local locale_conf="${EROOT%/}/etc/locale.conf"
+
+       if [[ ! -L ${locale_conf} && ! -e ${locale_conf} ]]; then
+               # If locale.conf does not exist...
+               if [[ -e ${envd_locale} ]]; then
+                       # ...either copy env.d/??locale if there's one
+                       ebegin "Moving ${envd_locale} to ${locale_conf}"
+                       mv "${envd_locale}" "${locale_conf}"
+                       eend ${?} || FAIL=1
+               else
+                       # ...or create a dummy default
+                       ebegin "Creating ${locale_conf}"
+                       cat > "${locale_conf}" <<-EOF
+                               # This file has been created by the sys-apps/systemd ebuild.
+                               # See locale.conf(5) and localectl(1).
+
+                               # LANG=${LANG}
+                       EOF
+                       eend ${?} || FAIL=1
+               fi
+       fi
+
+       if [[ ! -L ${envd_locale} ]]; then
+               # now, if env.d/??locale is not a symlink (to locale.conf)...
+               if [[ -e ${envd_locale} ]]; then
+                       # ...warn the user that he has duplicate locale settings
+                       ewarn
+                       ewarn "To ensure consistent behavior, you should replace ${envd_locale}"
+                       ewarn "with a symlink to ${locale_conf}. Please migrate your settings"
+                       ewarn "and create the symlink with the following command:"
+                       ewarn "ln -s -n -f ../locale.conf ${envd_locale}"
+                       ewarn
+               else
+                       # ...or just create the symlink if there's nothing here
+                       ebegin "Creating ${envd_locale_def} -> ../locale.conf symlink"
+                       ln -n -s ../locale.conf "${envd_locale_def}"
+                       eend ${?} || FAIL=1
+               fi
+       fi
+}
+
+migrate_net_name_slot() {
+       # If user has disabled 80-net-name-slot.rules using a empty file or a symlink to /dev/null,
+       # do the same for 80-net-setup-link.rules to keep the old behavior
+       local net_move=no
+       local net_name_slot_sym=no
+       local net_rules_path="${EROOT%/}"/etc/udev/rules.d
+       local net_name_slot="${net_rules_path}"/80-net-name-slot.rules
+       local net_setup_link="${net_rules_path}"/80-net-setup-link.rules
+       if [[ -e ${net_setup_link} ]]; then
+               net_move=no
+       elif [[ -f ${net_name_slot} && $(sed -e "/^#/d" -e "/^\W*$/d" ${net_name_slot} | wc -l) == 0 ]]; then
+               net_move=yes
+       elif [[ -L ${net_name_slot} && $(readlink ${net_name_slot}) == /dev/null ]]; then
+               net_move=yes
+               net_name_slot_sym=yes
+       fi
+       if [[ ${net_move} == yes ]]; then
+               ebegin "Copying ${net_name_slot} to ${net_setup_link}"
+
+               if [[ ${net_name_slot_sym} == yes ]]; then
+                       ln -nfs /dev/null "${net_setup_link}"
+               else
+                       cp "${net_name_slot}" "${net_setup_link}"
+               fi
+               eend $? || FAIL=1
+       fi
+}
+
+reenable_unit() {
+       if systemctl is-enabled --root="${ROOT}" "$1" &> /dev/null; then
+               ebegin "Re-enabling $1"
+               systemctl reenable --root="${ROOT}" "$1"
+               eend $? || FAIL=1
+       fi
+}
+
+pkg_postinst() {
+       newusergroup() {
+               enewgroup "$1"
+               enewuser "$1" -1 -1 -1 "$1"
+       }
+
+       enewgroup input
+       enewgroup systemd-journal
+       newusergroup systemd-bus-proxy
+       newusergroup systemd-journal-gateway
+       newusergroup systemd-journal-remote
+       newusergroup systemd-journal-upload
+       newusergroup systemd-network
+       newusergroup systemd-resolve
+       newusergroup systemd-timesync
+       use http && newusergroup systemd-journal-gateway
+
+       systemd_update_catalog
+
+       # Keep this here in case the database format changes so it gets updated
+       # when required. Despite that this file is owned by sys-apps/hwids.
+       if has_version "sys-apps/hwids[udev]"; then
+               udevadm hwdb --update --root="${ROOT%/}"
+       fi
+
+       udev_reload || FAIL=1
+
+       # Bug 465468, make sure locales are respect, and ensure consistency
+       # between OpenRC & systemd
+       migrate_locale
+
+       # Migrate 80-net-name-slot.rules -> 80-net-setup-link.rules
+       migrate_net_name_slot
+
+       # Re-enable systemd-networkd for socket activation
+       reenable_unit systemd-networkd.service
+
+       if [[ ${FAIL} ]]; then
+               eerror "One of the postinst commands failed. Please check the postinst output"
+               eerror "for errors. You may need to clean up your system and/or try installing"
+               eerror "systemd again."
+               eerror
+       fi
+
+       if [[ $(readlink "${ROOT}"/etc/resolv.conf) == */run/systemd/network/resolv.conf ]]; then
+               ewarn "resolv.conf is now generated by systemd-resolved. To use it, enable"
+               ewarn "systemd-resolved.service, and create a symlink from /etc/resolv.conf"
+               ewarn "to /run/systemd/resolve/resolv.conf"
+               ewarn
+       fi
+}
+
+pkg_prerm() {
+       # If removing systemd completely, remove the catalog database.
+       if [[ ! ${REPLACED_BY_VERSION} ]]; then
+               rm -f -v "${EROOT}"/var/lib/systemd/catalog/database
+       fi
+}