Fixed bug#168051, cleanup
authorAlon Bar-Lev <alonbl@gentoo.org>
Fri, 23 Feb 2007 15:30:10 +0000 (15:30 +0000)
committerAlon Bar-Lev <alonbl@gentoo.org>
Fri, 23 Feb 2007 15:30:10 +0000 (15:30 +0000)
Package-Manager: portage-2.1.2-r10

app-crypt/tpm-emulator/ChangeLog
app-crypt/tpm-emulator/files/digest-tpm-emulator-0.2a [deleted file]
app-crypt/tpm-emulator/files/tpm-emulator-0.2a-inline.patch [deleted file]
app-crypt/tpm-emulator/tpm-emulator-0.2a.ebuild [deleted file]
app-crypt/tpm-emulator/tpm-emulator-0.3.ebuild
app-crypt/tpm-module/ChangeLog
app-crypt/tpm-module/tpm-module-2.0.ebuild

index 0a5cd4fc151b6d4c7d6fc75f5d8c24f8a2804508..44c05b39ae95c87b9ee0c12c79f5fb627e6c8b4d 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-crypt/tpm-emulator
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/ChangeLog,v 1.5 2007/01/24 17:11:52 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/ChangeLog,v 1.6 2007/02/23 15:25:35 alonbl Exp $
+
+  23 Feb 2007; Alon Bar-Lev <alonbl@gentoo.org>
+  -files/tpm-emulator-0.2a-inline.patch, -tpm-emulator-0.2a.ebuild,
+  tpm-emulator-0.3.ebuild:
+  Fixed bug#168051, cleanup
 
   24 Jan 2007; Marius Mauch <genone@gentoo.org> tpm-emulator-0.2a.ebuild,
   tpm-emulator-0.3.ebuild:
diff --git a/app-crypt/tpm-emulator/files/digest-tpm-emulator-0.2a b/app-crypt/tpm-emulator/files/digest-tpm-emulator-0.2a
deleted file mode 100644 (file)
index 9cc29c1..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e58fc0cf77348d30ba7cbeacce20eefc tpm_emulator-0.2a.tar.gz 100306
-RMD160 8e9fffa984ddcfc0f33810d085ae8271b8bf4287 tpm_emulator-0.2a.tar.gz 100306
-SHA256 a87390f10198fdbaf28cc710280522cb88d6e6b3335d79f6d8e572b11cbac629 tpm_emulator-0.2a.tar.gz 100306
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator-0.2a-inline.patch b/app-crypt/tpm-emulator/files/tpm-emulator-0.2a-inline.patch
deleted file mode 100644 (file)
index ebeb271..0000000
+++ /dev/null
@@ -1,148 +0,0 @@
---- tpm_marshalling.c.orig     2005-05-07 17:57:21.000000000 +1000
-+++ tpm_marshalling.c  2005-06-23 21:46:08.000000000 +1000
-@@ -20,7 +20,7 @@
- #include "crypto/rsa.h"
- #include "linux_module.h"
--inline int tpm_marshal_BYTE(BYTE **ptr, UINT32 *length, BYTE v)
-+ int tpm_marshal_BYTE(BYTE **ptr, UINT32 *length, BYTE v)
- {
-   if (*length < 1) return -1;
-   **ptr = v;
-@@ -28,7 +28,7 @@
-   return 0;
- }
--inline int tpm_unmarshal_BYTE(BYTE **ptr, UINT32 *length, BYTE *v)
-+ int tpm_unmarshal_BYTE(BYTE **ptr, UINT32 *length, BYTE *v)
- {
-   if (*length < 1) return -1;
-   *v = **ptr;
-@@ -36,7 +36,7 @@
-   return 0;
- }
--inline int tpm_marshal_UINT16(BYTE **ptr, UINT32 *length, UINT16 v)
-+ int tpm_marshal_UINT16(BYTE **ptr, UINT32 *length, UINT16 v)
- {
-   if (*length < 2) return -1;
-   **(UINT16**)ptr = CPU_TO_BE16(v);
-@@ -44,7 +44,7 @@
-   return 0;
- }
--inline int tpm_unmarshal_UINT16(BYTE **ptr, UINT32 *length, UINT16 *v)
-+ int tpm_unmarshal_UINT16(BYTE **ptr, UINT32 *length, UINT16 *v)
- {
-   if (*length < 2) return -1;
-   *v = BE16_TO_CPU(**(UINT16**)ptr);
-@@ -52,7 +52,7 @@
-   return 0;
- }
--inline int tpm_marshal_UINT32(BYTE **ptr, UINT32 *length, UINT32 v)
-+ int tpm_marshal_UINT32(BYTE **ptr, UINT32 *length, UINT32 v)
- {
-   if (*length < 4) return -1;
-   **(UINT32**)ptr = CPU_TO_BE32(v);
-@@ -60,7 +60,7 @@
-   return 0;
- }
--inline int tpm_unmarshal_UINT32(BYTE **ptr, UINT32 *length, UINT32 *v)
-+ int tpm_unmarshal_UINT32(BYTE **ptr, UINT32 *length, UINT32 *v)
- {
-   if (*length < 4) return -1;
-   *v = BE32_TO_CPU(**(UINT32**)ptr);
-@@ -68,7 +68,7 @@
-   return 0;
- }
--inline int tpm_marshal_UINT64(BYTE **ptr, UINT32 *length, UINT64 v)
-+ int tpm_marshal_UINT64(BYTE **ptr, UINT32 *length, UINT64 v)
- {
-   if (*length < 8) return -1;
-   **(UINT64**)ptr = CPU_TO_BE64(v);
-@@ -76,7 +76,7 @@
-   return 0;
- }
--inline int tpm_unmarshal_UINT64(BYTE **ptr, UINT32 *length, UINT64 *v)
-+ int tpm_unmarshal_UINT64(BYTE **ptr, UINT32 *length, UINT64 *v)
- {
-   if (*length < 8) return -1;
-   *v = BE64_TO_CPU(**(UINT64**)ptr);
-@@ -84,7 +84,7 @@
-   return 0;
- }
--inline int tpm_marshal_BLOB(BYTE **ptr, UINT32 *ptr_length,
-+ int tpm_marshal_BLOB(BYTE **ptr, UINT32 *ptr_length,
-                             BYTE *b, UINT32 b_length)
- {
-   if (*ptr_length < b_length) return -1;
-@@ -93,7 +93,7 @@
-   return 0;
- }
--inline int tpm_unmarshal_BLOB(BYTE **ptr, UINT32 *ptr_length,
-+ int tpm_unmarshal_BLOB(BYTE **ptr, UINT32 *ptr_length,
-                               BYTE **b, UINT32 b_length)
- {
-   if (*ptr_length < b_length) return -1;
-@@ -102,7 +102,7 @@
-   return 0;
- }
--inline int tpm_marshal_BYTE_ARRAY(BYTE **ptr, UINT32 *ptr_length,
-+ int tpm_marshal_BYTE_ARRAY(BYTE **ptr, UINT32 *ptr_length,
-                                   BYTE *b, UINT32 b_length)
- {
-   if (*ptr_length < b_length) return -1;
-@@ -111,7 +111,7 @@
-   return 0;
- }
--inline int tpm_unmarshal_BYTE_ARRAY(BYTE **ptr, UINT32 *ptr_length,
-+ int tpm_unmarshal_BYTE_ARRAY(BYTE **ptr, UINT32 *ptr_length,
-                                     BYTE *b, UINT32 b_length)
- {
-   if (*ptr_length < b_length) return -1;
---- tpm_marshalling.h.orig     2005-05-07 17:57:21.000000000 +1000
-+++ tpm_marshalling.h  2005-06-23 21:46:08.000000000 +1000
-@@ -56,23 +56,23 @@
-  * returned and the values of ptr and length are undefined.
-  */
--inline int tpm_marshal_BYTE(BYTE **ptr, UINT32 *length, BYTE v);
--inline int tpm_unmarshal_BYTE(BYTE **ptr, UINT32 *length, BYTE *v);
-+ int tpm_marshal_BYTE(BYTE **ptr, UINT32 *length, BYTE v);
-+ int tpm_unmarshal_BYTE(BYTE **ptr, UINT32 *length, BYTE *v);
--inline int tpm_marshal_UINT16(BYTE **ptr, UINT32 *length, UINT16 v);
--inline int tpm_unmarshal_UINT16(BYTE **ptr, UINT32 *length, UINT16 *v);
-+ int tpm_marshal_UINT16(BYTE **ptr, UINT32 *length, UINT16 v);
-+ int tpm_unmarshal_UINT16(BYTE **ptr, UINT32 *length, UINT16 *v);
--inline int tpm_marshal_UINT32(BYTE **ptr, UINT32 *length, UINT32 v);
--inline int tpm_unmarshal_UINT32(BYTE **ptr, UINT32 *length, UINT32 *v);
-+ int tpm_marshal_UINT32(BYTE **ptr, UINT32 *length, UINT32 v);
-+ int tpm_unmarshal_UINT32(BYTE **ptr, UINT32 *length, UINT32 *v);
--inline int tpm_marshal_UINT64(BYTE **ptr, UINT32 *length, UINT64 v);
--inline int tpm_unmarshal_UINT64(BYTE **ptr, UINT32 *length, UINT64 *v);
-+ int tpm_marshal_UINT64(BYTE **ptr, UINT32 *length, UINT64 v);
-+ int tpm_unmarshal_UINT64(BYTE **ptr, UINT32 *length, UINT64 *v);
--inline int tpm_marshal_BLOB(BYTE **ptr, UINT32 *ptr_length, BYTE *b, UINT32 b_length);
--inline int tpm_unmarshal_BLOB(BYTE **ptr, UINT32 *ptr_length, BYTE **b, UINT32 b_length);
-+ int tpm_marshal_BLOB(BYTE **ptr, UINT32 *ptr_length, BYTE *b, UINT32 b_length);
-+ int tpm_unmarshal_BLOB(BYTE **ptr, UINT32 *ptr_length, BYTE **b, UINT32 b_length);
--inline int tpm_marshal_BYTE_ARRAY(BYTE **ptr, UINT32 *ptr_length, BYTE *b, UINT32 b_length);
--inline int tpm_unmarshal_BYTE_ARRAY(BYTE **ptr, UINT32 *ptr_length, BYTE *b, UINT32 b_length);
-+ int tpm_marshal_BYTE_ARRAY(BYTE **ptr, UINT32 *ptr_length, BYTE *b, UINT32 b_length);
-+ int tpm_unmarshal_BYTE_ARRAY(BYTE **ptr, UINT32 *ptr_length, BYTE *b, UINT32 b_length);
- #define tpm_marshal_BOOL                       tpm_marshal_BYTE
- #define tpm_unmarshal_BOOL                     tpm_unmarshal_BYTE
diff --git a/app-crypt/tpm-emulator/tpm-emulator-0.2a.ebuild b/app-crypt/tpm-emulator/tpm-emulator-0.2a.ebuild
deleted file mode 100644 (file)
index f5572b2..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/tpm-emulator-0.2a.ebuild,v 1.4 2007/01/24 17:11:52 genone Exp $
-
-inherit toolchain-funcs linux-mod eutils
-
-MY_P=${P/-/_}
-DESCRIPTION="Emulator driver for tpm"
-HOMEPAGE="https://developer.berlios.de/projects/tpm-emulator"
-
-SRC_URI="http://download.berlios.de/tpm-emulator/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND="dev-libs/gmp"
-RDEPEND=""
-S=${WORKDIR}/${PN/-/_}-0.2
-
-
-MODULE_NAMES="tpm_emulator(crypt:)"
-BUILD_TARGETS="all"
-BUILD_PARAMS="-j1 CC=$(tc-getCC) MODULE=tpm_emulator.${KV_OBJ} USE_GMP=/usr/lib/libgmp.a"
-
-# INCLUDE="${CFLAGS}"
-
-src_unpack() {
-       unpack ${A}
-       cd ${S}/tpm
-       epatch ${FILESDIR}/${P}-inline.patch
-}
-
-src_install() {
-       linux-mod_src_install
-       dodoc README
-}
-
-pkg_postinst() {
-       linux-mod_pkg_postinst
-       elog 'when starting for the first time:'
-       elog 'modprobe tpm_emulator startup="clear"'
-}
index a082586aba299d4b8e0413899ed644d29ba6fd21..068bb6a0a4a4c7490b0e74585657ff314a8bbd57 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/tpm-emulator-0.3.ebuild,v 1.4 2007/01/24 17:11:52 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/tpm-emulator-0.3.ebuild,v 1.5 2007/02/23 15:25:35 alonbl Exp $
 
 inherit toolchain-funcs linux-mod eutils flag-o-matic
 
@@ -19,9 +19,12 @@ RDEPEND=""
 S=${WORKDIR}/${P/-/_}
 
 
-MODULE_NAMES="tpm_emulator(crypt:)"
-BUILD_TARGETS="all"
-BUILD_PARAMS="-j1 CC=$(tc-getCC) MODULE=tpm_emulator.${KV_OBJ} USE_GMP=/usr/lib/libgmp.a"
+pkg_setup() {
+       linux-mod_pkg_setup
+       MODULE_NAMES="tpm_emulator(crypt:)"
+       BUILD_TARGETS="all"
+       BUILD_PARAMS="-j1 CC=$(tc-getCC) MODULE=tpm_emulator.${KV_OBJ} USE_GMP=/usr/lib/libgmp.a"
+}
 
 src_install() {
        linux-mod_src_install
index 963c3c8222a65b9564168d52266bc3714aa6c0bb..8123bdc0d4a96a3791af94919a6bc9460e7c045e 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-crypt/tpm-module
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-module/ChangeLog,v 1.2 2007/02/09 07:10:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-module/ChangeLog,v 1.3 2007/02/23 15:30:10 alonbl Exp $
+
+  23 Feb 2007; Alon Bar-Lev <alonbl@gentoo.org> tpm-module-2.0.ebuild:
+  Fixed bug#168051, cleanup
 
   09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
   Regenerate digest in Manifest2 format.
index ffd869c9470d5f83210e08e44b2535f3ac2d761c..485d2cecde36675c1be8829e414f224460074098 100644 (file)
@@ -1,25 +1,27 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-module/tpm-module-2.0.ebuild,v 1.1 2005/02/03 11:16:08 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-module/tpm-module-2.0.ebuild,v 1.2 2007/02/23 15:30:10 alonbl Exp $
 
 inherit linux-mod
 
 MY_P=tpm-${PV}
-S=${WORKDIR}/${MY_P}
 
 DESCRIPTION="Driver for TPM chips"
-
 HOMEPAGE="http://www.research.ibm.com/gsal/tcpa/"
 SRC_URI="http://www.research.ibm.com/gsal/tcpa/TPM-${PV}.tar.gz"
 
 LICENSE="GPL-2"
 KEYWORDS="~x86"
-
 IUSE=""
 
-BUILD_PARAMS="KDIR=${KV_DIR}"
-BUILD_TARGETS="default"
-MODULE_NAMES="tpm(crypto:)"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       linux-mod_pkg_setup
+       BUILD_PARAMS="KDIR=${KV_DIR}"
+       BUILD_TARGETS="default"
+       MODULE_NAMES="tpm(crypto:)"
+}
 
 src_unpack() {
        unpack ${A}