dev-lang/mono repair multilib-strict : Bug 554704
authorHeather Cynede <cynede@gentoo.org>
Sun, 16 Aug 2015 07:59:19 +0000 (11:59 +0400)
committerHeather Cynede <cynede@gentoo.org>
Sun, 16 Aug 2015 07:59:19 +0000 (11:59 +0400)
Package-Manager: portage-2.2.20.1

dev-lang/mono/mono-3.12.1.ebuild
dev-lang/mono/mono-4.0.3.20.ebuild

index 1952ade7f2f4492180c3539e29987ee073f81809..51416a4136ec2ca6a847903fb55f47102772c89d 100644 (file)
@@ -115,3 +115,13 @@ src_test() {
        cd mcs/tests || die
        emake check
 }
+
+src_install() {
+       autotools-utils_src_install
+
+       # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+       # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+       # for reference.
+       rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+       rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}
index 526b34b1b9c146b8c7e1377fe5a0da1ab78144da..0884626d5a86b3e561f64d09b8f4effcaf60f209 100644 (file)
@@ -104,3 +104,13 @@ src_test() {
        cd mcs/tests || die
        emake check
 }
+
+src_install() {
+       autotools-utils_src_install
+
+       # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+       # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+       # for reference.
+       rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+       rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}