dev-python/httplib2: Set readable bit for egg
authorJustin Lecher <jlec@gentoo.org>
Tue, 29 Sep 2015 08:19:36 +0000 (10:19 +0200)
committerJustin Lecher <jlec@gentoo.org>
Tue, 29 Sep 2015 08:34:45 +0000 (10:34 +0200)
Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/httplib2/httplib2-0.9.2-r1.ebuild [moved from dev-python/httplib2/httplib2-0.9.2.ebuild with 89% similarity]

similarity index 89%
rename from dev-python/httplib2/httplib2-0.9.2.ebuild
rename to dev-python/httplib2/httplib2-0.9.2-r1.ebuild
index 78cdde8b65badf9b896c1edd48100673ce3c57b3..20df28421041654381730f72b20928f5bc05730e 100644 (file)
@@ -22,6 +22,11 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 # tests connect to random remote sites
 RESTRICT="test"
 
+python_prepare_all() {
+       chmod o+r */*egg*/* || die
+       distutils-r1_python_prepare_all
+}
+
 python_test() {
        if [[ ${EPYTHON} == python2.7 ]] ; then
                cd python2 || die