Remove old ebuilds, add patch from bug 155955 to allow ciscoacl plugin to work with...
authorMarcelo Góes <vanquirius@gentoo.org>
Sat, 9 Dec 2006 16:03:26 +0000 (16:03 +0000)
committerMarcelo Góes <vanquirius@gentoo.org>
Sat, 9 Dec 2006 16:03:26 +0000 (16:03 +0000)
Package-Manager: portage-2.1.1-r2

net-analyzer/snortsam/ChangeLog
net-analyzer/snortsam/files/digest-snortsam-2.50-r1 [new file with mode: 0644]
net-analyzer/snortsam/snortsam-2.50-r1.ebuild [new file with mode: 0644]

index a63bd45e349ea9caf16e81cb0f4746dbb97fa549..eb05ec6d0829b68103069a9b2323812052ef3738 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-analyzer/snortsam
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snortsam/ChangeLog,v 1.17 2006/09/16 15:13:31 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snortsam/ChangeLog,v 1.18 2006/12/09 16:03:26 vanquirius Exp $
+
+*snortsam-2.50-r1 (09 Dec 2006)
+
+  09 Dec 2006; Marcelo Goes <vanquirius@gentoo.org> -snortsam-2.36.ebuild,
+  -snortsam-2.50.ebuild, +snortsam-2.50-r1.ebuild:
+  Remove old ebuilds, add patch from bug 155955 to allow ciscoacl plugin to
+  work with gcc-4.1.1. Thanks to Paul Kehrer <paul at victoly dot com>.
 
   16 Sep 2006; Markus Rothe <corsair@gentoo.org> snortsam-2.50.ebuild:
   Added ~ppc64
diff --git a/net-analyzer/snortsam/files/digest-snortsam-2.50-r1 b/net-analyzer/snortsam/files/digest-snortsam-2.50-r1
new file mode 100644 (file)
index 0000000..dd96d60
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 58eb357c54f7f7bf1d4a623ad09b9686 snortsam-2.50-ciscoacl.diff.bz2 7295
+RMD160 91d36fecc3fcf14de5ed964928d69ef3cc167bae snortsam-2.50-ciscoacl.diff.bz2 7295
+SHA256 a4f39789e9f10b95e6db1bbce5f9d26f7393161311f5c955a4b8380186a2cb6b snortsam-2.50-ciscoacl.diff.bz2 7295
+MD5 b599e706079c170ea53fc9ec3a184e88 snortsam-src-2.50.tar.gz 1073391
+RMD160 d4cc56f2f5d87254784f4b03b639bce943b8530d snortsam-src-2.50.tar.gz 1073391
+SHA256 3c77967f9ef581310de02443512fc7cd3f145249c9be765b1bcf679d408dc441 snortsam-src-2.50.tar.gz 1073391
diff --git a/net-analyzer/snortsam/snortsam-2.50-r1.ebuild b/net-analyzer/snortsam/snortsam-2.50-r1.ebuild
new file mode 100644 (file)
index 0000000..95f4852
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snortsam/snortsam-2.50-r1.ebuild,v 1.1 2006/12/09 16:03:26 vanquirius Exp $
+
+inherit eutils
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Snort plugin that allows automated blocking of IP addresses on several firewalls"
+HOMEPAGE="http://www.snortsam.net/"
+SRC_URI="http://www.snortsam.net/files/snortsam/${MY_P}.tar.gz
+       mirror://gentoo/${PN}-2.50-ciscoacl.diff.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}"/${PN}-2.29-no-ugly----lines.diff
+       # bug 155955, ciscoacl segfaults with gcc-4.1.1
+       epatch "${DISTDIR}"/${PN}-2.50-ciscoacl.diff.bz2
+}
+
+src_compile() {
+       sed -i "s: -O2 : ${CFLAGS} :" makesnortsam.sh || die "sed failed"
+       sh makesnortsam.sh || die "makesnortsam.sh failed"
+}
+
+src_install() {
+       find "${S}" -type d -name CVS -exec rm -rf {} \;
+       find "${S}" -type f -name "*.asc" -exec rm -f {} \;
+       dobin snortsam || die "dobin failed"
+       dodoc docs/* conf/*
+}
+
+pkg_postinst() {
+       einfo
+       einfo "To use snortsam with snort, you'll have to compile snort with USE=snortsam."
+       einfo "Read the INSTALL file to configure snort for snortsam, and configure"
+       einfo "snortsam for your particular firewall."
+       einfo
+
+}