mail-client/alot: Remove older version
authorAmadeusz Żołnowski <aidecoe@gentoo.org>
Mon, 17 Aug 2015 22:41:22 +0000 (23:41 +0100)
committerAmadeusz Żołnowski <aidecoe@gentoo.org>
Mon, 17 Aug 2015 22:42:44 +0000 (23:42 +0100)
Package-Manager: portage-2.2.20.1

mail-client/alot/Manifest
mail-client/alot/alot-0.3.5.ebuild [deleted file]
mail-client/alot/files/0.3.5-0001-Use-Unicode-strings-when-dealing-with-.patch [deleted file]

index 3104fe5b10f83619e510b61d5686375f74dae4ff..55c4496826eb2b7d67eeff9173d16cd49b5a46fa 100644 (file)
@@ -1,2 +1 @@
-DIST alot-0.3.5.tar.gz 1201061 SHA256 7f273b0657e7ee22fd65d6030a536c99ced39d6537c17eb186187923daa9125a SHA512 e781f63971dd1df46f221d0a11e14e4d0e1cb3a307ac317e950a53e28445130822c9d65c3bc99489d68500d4cc864c38c06f3f79e5fe98813d049a0dde22c22c WHIRLPOOL 1dc67524f0be9eb3088ce0710fa06205ac80dc63b3b194fc3bf0cb9a8c35139723372de27a21c466b8c3f3b01a6b4bb47fbdda109e3e13d915ef11fc72eebe37
 DIST alot-0.3.6.tar.gz 1492278 SHA256 b8e6092f18e503a528e934231c448db0e03d00e11d844192ba7eeb483838fee7 SHA512 30037ca1d2c169dda6c1660a24dadee12c6b5858d733ec7cd78e49d633850eecb763852c16565340596e32a6831ff8c36764d3f812de7f7947584defe05322b4 WHIRLPOOL cd4aab9dd84a441b92f5d4c62c783d58d8c4fafca614bf8bf462c1b3f0ffb4266e083380712b16f9469a0b418af1672625a21a6ae1f82f6623c6c22e005be6e9
diff --git a/mail-client/alot/alot-0.3.5.ebuild b/mail-client/alot/alot-0.3.5.ebuild
deleted file mode 100644 (file)
index c3299d1..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils vcs-snapshot
-
-DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
-HOMEPAGE="https://github.com/pazz/alot"
-SRC_URI="${HOMEPAGE}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       "
-RDEPEND="
-       >=dev-python/configobj-4.6.0[${PYTHON_USEDEP}]
-       dev-python/pygpgme[${PYTHON_USEDEP}]
-       >=dev-python/twisted-core-10.2.0
-       >=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]
-       net-mail/mailbase
-       >=net-mail/notmuch-0.13[crypt,python]
-       sys-apps/file[python]
-       "
-
-ALOT_UPDATE=""
-
-pkg_setup() {
-       if has_version "<${CATEGORY}/${PN}-0.3.2"; then
-               ALOT_UPDATE="yes"
-       fi
-}
-
-src_prepare() {
-       epatch "${FILESDIR}/${PV}-0001-Use-Unicode-strings-when-dealing-with-.patch"
-
-       find "${S}" -name '*.py' -print0 | xargs -0 -- sed \
-               -e '1i# -*- coding: utf-8 -*-' -i || die
-
-       distutils-r1_src_prepare
-
-       local md
-       for md in *.md; do
-               mv "${md}" "${md%.md}"
-       done
-}
-
-src_compile() {
-       distutils-r1_src_compile
-
-       if use doc; then
-               pushd docs || die
-               emake html
-               popd || die
-       fi
-}
-
-src_install() {
-       distutils-r1_src_install
-
-       dodir /usr/share/alot
-       insinto /usr/share/alot
-       doins -r extra
-
-       if use doc; then
-               dohtml -r docs/build/html/*
-       fi
-}
-
-pkg_postinst() {
-       if [[ ${ALOT_UPDATE} = yes ]]; then
-               ewarn "The syntax of theme-files and custom tags-sections of the config"
-               ewarn "has been changed.  You have to revise your config.  There are"
-               ewarn "converter scripts in /usr/share/alot/extra to help you out with"
-               ewarn "this:"
-               ewarn ""
-               ewarn "  * tagsections_convert.py for your ~/.config/alot/config"
-               ewarn "  * theme_convert.py to update your custom theme files"
-       fi
-}
diff --git a/mail-client/alot/files/0.3.5-0001-Use-Unicode-strings-when-dealing-with-.patch b/mail-client/alot/files/0.3.5-0001-Use-Unicode-strings-when-dealing-with-.patch
deleted file mode 100644 (file)
index c7809fa..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-From 119e15cae5367d86e3754a337558eb98a420f46a Mon Sep 17 00:00:00 2001
-From: Simon Chopin <chopin.simon@gmail.com>
-Date: Wed, 24 Jul 2013 15:13:20 +0200
-Subject: [PATCH] Use Unicode strings when dealing with GPG
-
-This delays the encoding of special chars, if any, to the actual display
-which is supposed to know into what it should be encoded.
----
- alot/db/utils.py | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/alot/db/utils.py b/alot/db/utils.py
-index ba6d466..7fb2deb 100644
---- a/alot/db/utils.py
-+++ b/alot/db/utils.py
-@@ -51,9 +51,9 @@ def add_signature_headers(mail, sigs, error_msg):
-     )
-     mail.add_header(
-         X_SIGNATURE_MESSAGE_HEADER,
--        'Invalid: {0}'.format(error_msg)
-+        u'Invalid: {0}'.format(error_msg)
-         if error_msg else
--        'Valid: {0}'.format(sig_from),
-+        u'Valid: {0}'.format(sig_from),
-     )
-@@ -104,19 +104,19 @@ def message_from_file(handle):
-         malformed = False
-         if len(m.get_payload()) != 2:
--            malformed = 'expected exactly two messages, got {0}'.format(
-+            malformed = u'expected exactly two messages, got {0}'.format(
-                 len(m.get_payload()))
-         ct = m.get_payload(1).get_content_type()
-         if ct != app_pgp_sig:
--            malformed = 'expected Content-Type: {0}, got: {1}'.format(
-+            malformed = u'expected Content-Type: {0}, got: {1}'.format(
-                 app_pgp_sig, ct)
-         # TODO: RFC 3156 says the alg has to be lower case, but I've
-         # seen a message with 'PGP-'. maybe we should be more
-         # permissive here, or maybe not, this is crypto stuff...
-         if not p.get('micalg', 'nothing').startswith('pgp-'):
--            malformed = 'expected micalg=pgp-..., got: {0}'.format(
-+            malformed = u'expected micalg=pgp-..., got: {0}'.format(
-                 p.get('micalg', 'nothing'))
-         sigs = []
-@@ -144,13 +144,13 @@ def message_from_file(handle):
-         ct = m.get_payload(0).get_content_type()
-         if ct != app_pgp_enc:
--            malformed = 'expected Content-Type: {0}, got: {1}'.format(
-+            malformed = u'expected Content-Type: {0}, got: {1}'.format(
-                 app_pgp_enc, ct)
-         want = 'application/octet-stream'
-         ct = m.get_payload(1).get_content_type()
-         if ct != want:
--            malformed = 'expected Content-Type: {0}, got: {1}'.format(want, ct)
-+            malformed = u'expected Content-Type: {0}, got: {1}'.format(want, ct)
-         if not malformed:
-             try:
-@@ -199,7 +199,7 @@ def message_from_file(handle):
-                     add_signature_headers(m, sigs, '')
-         if malformed:
--            msg = 'Malformed OpenPGP message: {0}'.format(malformed)
-+            msg = u'Malformed OpenPGP message: {0}'.format(malformed)
-             m.attach(email.message_from_string(msg))
-     return m
--- 
-1.8.3.2
-