dev-python/pyalsaaudio: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:52 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:52 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild
dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild

index 687e556b8ed57f6a491957c986bad97539f75c97..cc8e0a892d3b9404ecb2453f94a1bbf039651d8f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -32,7 +32,11 @@ python_compile_all() {
 
 python_install_all() {
        use doc && local HTML_DOCS=( doc/html/. )
-       local EXAMPLES=( *test.py )
+       if use examples; then
+               docinto examples
+               dodoc *test.py
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
 
        distutils-r1_python_install_all
 }
index 86ab4f4bfb56a67c06d8d1bf000590fc9ef74f74..755668b93831341013fa839c4b960cd5dca8ce5e 100644 (file)
@@ -39,7 +39,11 @@ python_test() {
 
 python_install_all() {
        use doc && local HTML_DOCS=( doc/html/. )
-       local EXAMPLES=( *test.py )
+       if use examples; then
+               docinto examples
+               dodoc *test.py
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
 
        distutils-r1_python_install_all
 }