games-emulation/higan: eutils->desktop
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 3 Aug 2018 01:49:28 +0000 (20:49 -0500)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 27 Aug 2018 21:16:15 +0000 (22:16 +0100)
Only ahs eutils for the implicit desktop inheritance for doicon and
make_desktop_entry.

Package-Manager: Portage-2.3.44, Repoman-2.3.10

games-emulation/higan/higan-106_p1-r1.ebuild

index a39e0db7e72963ac4ac35c4b3eedf25d1191d0ae..afaa222f9248c1b22489ba9719353276d2e9bd33 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit eutils gnome2-utils toolchain-funcs qmake-utils
+inherit desktop gnome2-utils toolchain-funcs qmake-utils
 
 MY_COMMIT=41efdba45afa770db99bc7484a8ad340ccc597d2
 
@@ -47,6 +47,11 @@ DEPEND="${RDEPEND}
 
 S=${WORKDIR}/${PN}-${MY_COMMIT}-${MY_COMMIT}
 
+PATCHES=(
+       "${FILESDIR}"/${P}-header-locations.patch
+       "${FILESDIR}"/${P}-QA.patch
+)
+
 disable_module() {
        sed -i \
                -e "s|$1\b||" \
@@ -54,15 +59,11 @@ disable_module() {
 }
 
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-header-locations.patch
-       epatch "${FILESDIR}"/${P}-QA.patch
-
+       default
        sed -i \
                -e "/handle/s#/usr/local/lib#/usr/$(get_libdir)#" \
                nall/dl.hpp || die "fixing libdir failed!"
 
-       eapply_user
-
        # audio modules
        use ao || disable_module audio.ao
        use openal || disable_module audio.openal