dev-libs/libgit2: Bump to 0.27.8 (bugfix)
authorMichał Górny <mgorny@gentoo.org>
Tue, 29 Jan 2019 13:15:34 +0000 (14:15 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 29 Jan 2019 13:15:34 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/libgit2/Manifest
dev-libs/libgit2/libgit2-0.27.8.ebuild [new file with mode: 0644]

index 4711943e3e0248d92d09400180831a81bdc321ad..c7dfcc2dddadefbdf2ca62b4bc5f84632821816d 100644 (file)
@@ -1,2 +1,3 @@
 DIST libgit2-0.26.8.tar.gz 4742478 BLAKE2B 31326987961ed42740f6c0ddce6a80c278175899a62cabd65ce9eef60854553e6a91fd9947ca23945104d4e1b46f9ab0bb1a1a793d8dd87bed792528e5c32839 SHA512 efb9229b2882ac36910d75778d7431bec40f3529f2ad2dd6a950d5580ceb0d4dd798242a422ea6cbb880f515df4dfbb7055a65dd5a8106696d3d458851fca56e
 DIST libgit2-0.27.7.tar.gz 4782856 BLAKE2B c844eca24b5053b3391ace6ebeea047bbba4fd429786e08144151109bfbd22f5c1b2609a176816a5d7eff63f1fe91122f88d89d3613dc4c770051cf095ae5ac3 SHA512 de2e266939bd40bc580603539e1156906b97299523336ddc6a66c3bec26729495bef2daa2d240b83b7e011e93852381e95a4407132b0440a5aa1e1b7642c0011
+DIST libgit2-0.27.8.tar.gz 4783928 BLAKE2B 0f0f79a43de3e869d593dafc1b506ee0894143d2daedf2fe56683ad8f2edfd7d87bab784354b9fb1796fa8e08a36b9de88af65c7621a90d537cb585c89118197 SHA512 53ab69a0687afd315029fdbe0ce8192b7e88f7f1ff6bc9c4875718e638cecd64755a9942ad605e6c388c58c6b892b351d54c5405de8e0d5ba90406055a25ffaa
diff --git a/dev-libs/libgit2/libgit2-0.27.8.ebuild b/dev-libs/libgit2/libgit2-0.27.8.ebuild
new file mode 100644 (file)
index 0000000..3815701
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit cmake-utils python-any-r1
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.github.com/"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/27"
+IUSE="+curl examples gssapi libressl +ssh test +threads trace"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       sys-libs/zlib
+       net-libs/http-parser:=
+       curl? (
+               !libressl? ( net-misc/curl:=[curl_ssl_openssl(-)] )
+               libressl? ( net-misc/curl:=[curl_ssl_libressl(-)] )
+       )
+       gssapi? ( virtual/krb5 )
+       ssh? ( net-libs/libssh2 )
+"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       virtual/pkgconfig
+"
+
+DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
+
+PATCHES=(
+       # skip OOM tests on 32-bit systems
+       # https://bugs.gentoo.org/669892
+       # https://github.com/libgit2/libgit2/commit/415a8ae9c9b6ac18f0524b6af8e58408b426457d
+       "${FILESDIR}"/libgit2-0.26.8-disable-oom-tests-on-32bit.patch
+)
+
+src_configure() {
+       local mycmakeargs=(
+               -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+               -DBUILD_CLAR=$(usex test)
+               -DENABLE_TRACE=$(usex trace)
+               -DUSE_GSSAPI=$(usex gssapi)
+               -DUSE_SSH=$(usex ssh)
+               -DTHREADSAFE=$(usex threads)
+               -DCURL=$(usex curl)
+       )
+       cmake-utils_src_configure
+}
+
+src_test() {
+       if [[ ${EUID} -eq 0 ]] ; then
+               # repo::iterator::fs_preserves_error fails if run as root
+               # since root can still access dirs with 0000 perms
+               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+       else
+               local TEST_VERBOSE=1
+               cmake-utils_src_test -R offline
+       fi
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       if use examples ; then
+               find examples -name '.gitignore' -delete || die
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}