dev-python/PyQt5: rename USE=gles2 to USE=gles2-only
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Sat, 23 Nov 2019 09:10:13 +0000 (10:10 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Apr 2020 20:05:25 +0000 (22:05 +0200)
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/PyQt5/PyQt5-5.13.2-r1.ebuild [moved from dev-python/PyQt5/PyQt5-5.13.2.ebuild with 94% similarity]
dev-python/PyQt5/PyQt5-5.14.1-r1.ebuild [moved from dev-python/PyQt5/PyQt5-5.14.1.ebuild with 94% similarity]
dev-python/PyQt5/metadata.xml

similarity index 94%
rename from dev-python/PyQt5/PyQt5-5.13.2.ebuild
rename to dev-python/PyQt5/PyQt5-5.13.2-r1.ebuild
index bb4a3e363f4efe96492640943290e55988896e1b..4b62cb09301165100e731f238f4cbd02f8d4afa8 100644 (file)
@@ -21,7 +21,7 @@ SLOT="0"
 KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 x86"
 
 # TODO: QtNfc, QtRemoteObjects (Qt >= 5.12)
-IUSE="bluetooth dbus debug declarative designer examples gles2 gui help location multimedia
+IUSE="bluetooth dbus debug declarative designer examples gles2-only gui help location multimedia
        network networkauth opengl positioning printsupport sensors serialport sql +ssl svg
        testlib webchannel webkit websockets widgets x11extras xmlpatterns"
 
@@ -69,7 +69,7 @@ RDEPEND="
        )
        declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
        designer? ( >=dev-qt/designer-${QT_PV} )
-       gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
+       gui? ( >=dev-qt/qtgui-${QT_PV}[gles2-only=] )
        help? ( >=dev-qt/qthelp-${QT_PV} )
        location? ( >=dev-qt/qtlocation-${QT_PV} )
        multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
@@ -128,9 +128,9 @@ src_configure() {
                        $(usex declarative '' --no-qml-plugin)
                        $(pyqt_use_enable designer)
                        $(usex designer '' --no-designer-plugin)
-                       $(usex gles2 '--disable-feature=PyQt_Desktop_OpenGL' '')
+                       $(usex gles2-only '--disable-feature=PyQt_Desktop_OpenGL' '')
                        $(pyqt_use_enable gui)
-                       $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
+                       $(pyqt_use_enable gui $(use gles2-only && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
                        $(pyqt_use_enable help)
                        $(pyqt_use_enable location)
                        $(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
similarity index 94%
rename from dev-python/PyQt5/PyQt5-5.14.1.ebuild
rename to dev-python/PyQt5/PyQt5-5.14.1-r1.ebuild
index 1a712c4cf85db79db78cae8219174eca8389b247..d8ef5f3a330b095d38566040c0eb7efb84975f14 100644 (file)
@@ -21,7 +21,7 @@ SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
 
 # TODO: QtNfc, QtRemoteObjects (Qt >= 5.12)
-IUSE="bluetooth dbus debug declarative designer examples gles2 gui help location multimedia
+IUSE="bluetooth dbus debug declarative designer examples gles2-only gui help location multimedia
        network networkauth opengl positioning printsupport sensors serialport sql +ssl svg
        testlib webchannel webkit websockets widgets x11extras xmlpatterns"
 
@@ -69,7 +69,7 @@ RDEPEND="
        )
        declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
        designer? ( >=dev-qt/designer-${QT_PV} )
-       gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
+       gui? ( >=dev-qt/qtgui-${QT_PV}[gles2-only=] )
        help? ( >=dev-qt/qthelp-${QT_PV} )
        location? ( >=dev-qt/qtlocation-${QT_PV} )
        multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
@@ -128,9 +128,9 @@ src_configure() {
                        $(usex declarative '' --no-qml-plugin)
                        $(pyqt_use_enable designer)
                        $(usex designer '' --no-designer-plugin)
-                       $(usex gles2 '--disable-feature=PyQt_Desktop_OpenGL' '')
+                       $(usex gles2-only '--disable-feature=PyQt_Desktop_OpenGL' '')
                        $(pyqt_use_enable gui)
-                       $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
+                       $(pyqt_use_enable gui $(use gles2-only && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
                        $(pyqt_use_enable help)
                        $(pyqt_use_enable location)
                        $(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
index d337ce9c469781a265a06fe981eaf869f9e9a24d..fc69b98a7a4dc9648647d108146ad193468642ad 100644 (file)
@@ -10,7 +10,6 @@
                <flag name="dbus">Build bindings for the QtDBus module</flag>
                <flag name="declarative">Build bindings for the QtQml/QtQuick modules and enable the qmlscene plugin</flag>
                <flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
-               <flag name="gles2">Use GLES 2.0 or later instead of full OpenGL</flag>
                <flag name="gui">Build bindings for the QtGui module</flag>
                <flag name="help">Build bindings for the QtHelp module</flag>
                <flag name="location">Build bindings for the QtLocation module</flag>