net-analyzer/nload: patch to fix text sliding effect
authorAndrey Mazo <ahippo@yandex.com>
Sun, 12 Aug 2018 02:11:12 +0000 (05:11 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 07:18:42 +0000 (09:18 +0200)
Apply the following patch from upstream:
8a93886 "Eliminate flicker on some terminals like rxvt (thanks to Alex Wilson)"

This fixes network utilization graph rendering issue.
(the text on the right side of the screen
slides to the left together with graph updates)

Closes: https://bugs.gentoo.org/663402
Closes: https://github.com/gentoo/gentoo/pull/9543
Package-Manager: Portage-2.3.40, Repoman-2.3.9

net-analyzer/nload/files/nload-0.7.4-Eliminate-flicker-on-some-terminals.patch [new file with mode: 0644]
net-analyzer/nload/nload-0.7.4-r1.ebuild

diff --git a/net-analyzer/nload/files/nload-0.7.4-Eliminate-flicker-on-some-terminals.patch b/net-analyzer/nload/files/nload-0.7.4-Eliminate-flicker-on-some-terminals.patch
new file mode 100644 (file)
index 0000000..8d13545
--- /dev/null
@@ -0,0 +1,26 @@
+From 8a93886e0fb33a81b8fe32e88ee106a581fedd34 Mon Sep 17 00:00:00 2001
+From: Roland Riegel <roland@roland-riegel.de>
+Date: Sun, 28 Jan 2018 16:59:39 +0100
+Subject: [PATCH 1/1] Eliminate flicker on some terminals like rxvt (thanks to
+ Alex Wilson)
+
+---
+ src/window.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/window.cpp b/src/window.cpp
+index bfa7701..2083fd0 100644
+--- a/src/window.cpp
++++ b/src/window.cpp
+@@ -108,7 +108,7 @@ void Window::refresh()
+ void Window::clear()
+ {
+     if(m_window)
+-        wclear(m_window);
++        werase(m_window);
+ }
+ // move and resize window
+-- 
+2.16.4
+
index d65af8f42024758be698d126c9c012736d0ad7bb..1de5b57210386ffc6b7a39bae3b919d899654f83 100644 (file)
@@ -19,6 +19,7 @@ BDEPEND="virtual/pkgconfig"
 
 PATCHES=(
        "${FILESDIR}"/${P}-tinfo.patch
+       "${FILESDIR}"/${P}-Eliminate-flicker-on-some-terminals.patch
 )
 
 src_prepare() {