dev-util/devhelp: add py3.7 support, use python_gen_cond_dep
authorMart Raudsepp <leio@gentoo.org>
Sun, 26 Jan 2020 16:33:22 +0000 (18:33 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 26 Jan 2020 18:00:28 +0000 (20:00 +0200)
Closes: https://bugs.gentoo.org/702438
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-util/devhelp/devhelp-3.30.1.ebuild

index e00885f4d8ee9c8d3a31e6dddc3e3844b2aa5f39..014be70449d8d4034147f12adfd375057a0501f4 100644 (file)
@@ -2,9 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-# gedit-3.8 is python3 only, this also per:
-# https://bugzilla.redhat.com/show_bug.cgi?id=979450
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit gnome.org gnome2-utils meson python-single-r1 xdg
 
@@ -28,8 +26,11 @@ COMMON_DEPEND="
 RDEPEND="${COMMON_DEPEND}
        gedit? (
                ${PYTHON_DEPS}
-               app-editors/gedit[introspection,python,${PYTHON_USEDEP}]
-               dev-python/pygobject:3[${PYTHON_USEDEP}] )
+               $(python_gen_cond_dep '
+                       app-editors/gedit[introspection,python,${PYTHON_SINGLE_USEDEP}]
+                       dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+               ')
+       )
 "
 # libxml2 required for glib-compile-resources
 DEPEND="${COMMON_DEPEND}