dev-python/cryptography: Add back libressl support
authorJustin Lecher <jlec@gentoo.org>
Wed, 30 Sep 2015 06:35:35 +0000 (08:35 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 30 Sep 2015 10:32:45 +0000 (12:32 +0200)
Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/cryptography/cryptography-1.0.2.ebuild

index 6bc770ee9e5a7547721cb5921600e83a908d4ce1..e7979826cb92b6c74af9d1d9a6c5a23d9e4f9a3b 100644 (file)
@@ -16,10 +16,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="|| ( Apache-2.0 BSD )"
 SLOT="0"
 KEYWORDS="alpha amd64 ~arm hppa ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
+IUSE="libressl test"
 
 RDEPEND="
-        dev-libs/openssl:0
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
        $(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
        $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
        >=dev-python/idna-2.0[${PYTHON_USEDEP}]