all-shells/autojump: Make use of ${PN} and remove trailing spaces.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 7 Sep 2015 11:31:19 +0000 (11:31 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 7 Sep 2015 11:31:19 +0000 (11:31 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-shells/autojump/autojump-22.2.4-r1.ebuild

index 0364cca65d61b1f60aa01a9dc5ba71db9a6a1d5c..be4106d02ec1beb1e81537efcc3cbdfe359d00f8 100644 (file)
@@ -20,46 +20,43 @@ IUSE="bash-completion python test zsh-completion"
 # Not all tests pass. Need investigation.
 RESTRICT="test"
 RDEPEND="bash-completion? ( >=app-shells/bash-4 )
-        python? ( ${PYTHON_DEPS} )
-        zsh-completion? ( app-shells/zsh app-shells/gentoo-zsh-completions )"
-DEPEND="test? (
-                dev-python/flake8
-                dev-python/tox
-        )"
+       python? ( ${PYTHON_DEPS} )
+       zsh-completion? ( app-shells/zsh app-shells/gentoo-zsh-completions )"
+DEPEND="test? ( dev-python/flake8 dev-python/tox )"
 
 src_prepare() {
-        sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
-                -i bin/autojump.sh || die
+       sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+               -i bin/autojump.sh || die
 }
 
 src_compile() {
-        true
+       true
 }
 
 src_install() {
-        dobin bin/autojump
+       dobin bin/autojump
 
-        insinto /etc/profile.d
-        doins bin/${PN}.sh
+       insinto /etc/profile.d
+       doins bin/${PN}.sh
 
-        insinto /usr/local/share/autojump/
-        if use bash-completion ; then
-                doins bin/${PN}.bash
-        fi
+       insinto /usr/local/share/"${PN}"/
+       if use bash-completion ; then
+               doins bin/${PN}.bash
+       fi
 
-        if use zsh-completion ; then
-                doins bin/${PN}.zsh
-                insinto /usr/share/zsh/site-functions
-                doins bin/_j
-        fi
+       if use zsh-completion ; then
+               doins bin/${PN}.zsh
+               insinto /usr/share/zsh/site-functions
+               doins bin/_j
+       fi
 
-        if use python ; then
-                python_foreach_impl python_domodule tools/autojump_ipython.py bin/autojump_argparse.py bin/autojump_data.py bin/autojump_utils.py
+       if use python ; then
+               python_foreach_impl python_domodule tools/autojump_ipython.py bin/autojump_argparse.py bin/autojump_data.py bin/autojump_utils.py
 
-                einfo "This tool provides \"j\" for ipython, please add"
-                einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
-        fi
+               einfo "This tool provides \"j\" for ipython, please add"
+               einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
+       fi
 
-        doman docs/${PN}.1
-        dodoc README.md
+       doman docs/${PN}.1
+       dodoc README.md
 }