app-text/libetonyek: Fix build w/ mdds-1.2.0
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Sat, 4 Jun 2016 12:58:07 +0000 (14:58 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 7 Jun 2016 14:57:49 +0000 (16:57 +0200)
Patch taken from Debian. See also:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824584

Gentoo-bug: 584994

Package-Manager: portage-2.2.28
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-text/libetonyek/files/libetonyek-0.1.6-mdds-1.2.patch [new file with mode: 0644]
app-text/libetonyek/libetonyek-0.1.6.ebuild
app-text/libetonyek/libetonyek-9999.ebuild

diff --git a/app-text/libetonyek/files/libetonyek-0.1.6-mdds-1.2.patch b/app-text/libetonyek/files/libetonyek-0.1.6-mdds-1.2.patch
new file mode 100644 (file)
index 0000000..0ca085f
--- /dev/null
@@ -0,0 +1,33 @@
+--- libetonyek-0.1.6/configure.ac
++++ libetonyek-0.1.6/configure.ac
+@@ -24,8 +24,8 @@ AC_LANG([C++])
+ # Configure options
+ # =================
+ AC_ARG_WITH([mdds],
+-            AS_HELP_STRING([--with-mdds=1.0|0.x], [Specify which version of mdds to use (1.0 is the default)]),
+-            [], [with_mdds="1.0"])
++            AS_HELP_STRING([--with-mdds=1.2|0.x], [Specify which version of mdds to use (1.2 is the default)]),
++            [], [with_mdds="1.2"])
+ # ===========================
+ # Find required base packages
+@@ -47,7 +47,7 @@ AC_PROG_SED
+ AM_MISSING_PROG([GPERF], [gperf])
+-AS_IF([test "$with_mdds" = "1.0"], [AX_CXX_COMPILE_STDCXX_11([noext])])
++AS_IF([test "$with_mdds" = "1.2"], [AX_CXX_COMPILE_STDCXX_11([noext])])
+ # ===============
+ # Find librevenge
+@@ -138,8 +138,8 @@ AC_SUBST([GLM_CFLAGS])
+ # =========
+ # Find mdds
+ # =========
+-AS_IF([test "$with_mdds" = "1.0"], [
+-    PKG_CHECK_MODULES([MDDS], [mdds-1.0])
++AS_IF([test "$with_mdds" = "1.2"], [
++    PKG_CHECK_MODULES([MDDS], [mdds-1.2])
+ ], [
+     PKG_CHECK_MODULES([MDDS], [mdds])
+     AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
index 5dd60843431596c8e8a1cc68c1e8d28b4dc78598..b4a4e5b681a7bd316ba0150b716f9e660820d15e 100644 (file)
@@ -5,8 +5,8 @@
 EAPI=6
 
 EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libetonyek"
-inherit eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+inherit autotools eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
 
 DESCRIPTION="Library parsing Apple Keynote presentations"
 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
@@ -26,7 +26,7 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}
        dev-libs/boost
-       dev-util/mdds:1
+       >=dev-util/mdds-1.2.0:1
        media-libs/glm
        sys-devel/libtool
        virtual/pkgconfig
@@ -34,6 +34,8 @@ DEPEND="${RDEPEND}
        test? ( dev-util/cppunit )
 "
 
+PATCHES=( "${FILESDIR}/${P}-mdds-1.2.patch" ) # patch taken from Debian
+
 pkg_pretend() {
        if [[ $(gcc-major-version) -lt 4 ]] || {
                [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 8 ]]; }
@@ -44,9 +46,9 @@ pkg_pretend() {
 }
 
 src_prepare() {
-       eapply_user
+       default
        [[ -d m4 ]] || mkdir "m4"
-       [[ ${PV} == 9999 ]] && eautoreconf
+       eautoreconf
 }
 
 src_configure() {
index 71de2347d2efa5c15a07eb341ec36020c5c0a76e..3aa7b1ecc37be34dec231304c9d45371d4f24c24 100644 (file)
@@ -44,7 +44,7 @@ pkg_pretend() {
 }
 
 src_prepare() {
-       eapply_user
+       default
        [[ -d m4 ]] || mkdir "m4"
        [[ ${PV} == 9999 ]] && eautoreconf
 }