dev-python/traitlets: Add missing 4.3.3 ebuild
authorMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 17:46:16 +0000 (18:46 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 17:48:59 +0000 (18:48 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/traitlets/traitlets-4.3.3.ebuild [new file with mode: 0644]

diff --git a/dev-python/traitlets/traitlets-4.3.3.ebuild b/dev-python/traitlets/traitlets-4.3.3.ebuild
new file mode 100644 (file)
index 0000000..d013bd3
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configuration system for Python applications"
+HOMEPAGE="https://github.com/ipython/traitlets"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+       dev-python/decorator[${PYTHON_USEDEP}]
+       dev-python/ipython_genutils[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       "
+
+distutils_enable_sphinx docs \
+       dev-python/ipython_genutils
+distutils_enable_tests pytest