media-plugins/gst-plugins-srtp: Version bump, 1.16.2
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Tue, 21 Apr 2020 18:18:50 +0000 (20:18 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 3 May 2020 19:12:01 +0000 (22:12 +0300)
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-plugins/gst-plugins-srtp/Manifest
media-plugins/gst-plugins-srtp/files/gst-plugins-srtp-1.16.2-make43.patch [new file with mode: 0644]
media-plugins/gst-plugins-srtp/gst-plugins-srtp-1.16.2.ebuild [new file with mode: 0644]

index 7340942584bdbb0ef4093100e128e0c345845c58..cf517f25a29bd8631a300e52544d455b46027f3e 100644 (file)
@@ -1 +1,2 @@
 DIST gst-plugins-bad-1.14.5.tar.xz 4686916 BLAKE2B b22377fbadf54828e86cc4e0bb17fb9b25efe4394c64eeceb228084e58d0db595622670c6c0a2d87fb760fce34974f9e425a2b810460465130ce1a4c2c679e7d SHA512 64d2a9f6203fbeb3db19816f936f4db32dd8bb7d1f4ce1f958ae795f008e72946e8e2e8bcf8c456c33d5567cb66dc34ca95836c52e404835300a3a5f38d52b6b
+DIST gst-plugins-bad-1.16.2.tar.xz 4887812 BLAKE2B edf10aeb365d9a7cf4b5172af29b46cff4c7a49a3e4dde881469f5738b5a525eb51a6f70bb1dd6f680e4e48977d65769ac8e8f41d914b7ce7719b9fa260a7bd4 SHA512 aeaf3388156fe7317e193a3f940d391a6d8a1187f93e6925cee4cb02c4e78d9b456c22c27c318f0f9b2212ca68887c5cdcc256adaf068bfab8ec5c091a1e8805
diff --git a/media-plugins/gst-plugins-srtp/files/gst-plugins-srtp-1.16.2-make43.patch b/media-plugins/gst-plugins-srtp/files/gst-plugins-srtp-1.16.2-make43.patch
new file mode 100644 (file)
index 0000000..f5caac7
--- /dev/null
@@ -0,0 +1,200 @@
+diff --git a/common/glib-gen.mak b/common/glib-gen.mak
+index ef93a5f..cc02239 100644
+--- a/common/glib-gen.mak
++++ b/common/glib-gen.mak
+@@ -1,11 +1,13 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_enum_prefix=gst_color_balance
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers=$(foreach h,$(glib_enum_headers),\n${H}include \"$(h)\")
+ # these are all the rules generating the relevant files
+ %-marshal.h: %-marshal.list
+diff --git a/common/gst-glib-gen.mak b/common/gst-glib-gen.mak
+index 76b2233..5f2b1ed 100644
+--- a/common/gst-glib-gen.mak
++++ b/common/gst-glib-gen.mak
+@@ -1,6 +1,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -8,7 +10,7 @@
+ #glib_gen_decl_banner=GST_EXPORT
+ #glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers=$(foreach h,$(glib_enum_headers),\n${H}include \"$(h)\")
+ # these are all the rules generating the relevant files
+ $(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
+diff --git a/ext/srt/Makefile.in b/ext/srt/Makefile.in
+index 09109c3..e5f2a9d 100644
+--- a/ext/srt/Makefile.in
++++ b/ext/srt/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -794,7 +796,7 @@ noinst_HEADERS = \
+       gstsrtsrc.h \
+       $(NULL)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n${H}include \"$(h)\")
+ all: $(BUILT_SOURCES)
+       $(MAKE) $(AM_MAKEFLAGS) all-am
+diff --git a/ext/srtp/Makefile.in b/ext/srtp/Makefile.in
+index 758db8e..017c075 100644
+--- a/ext/srtp/Makefile.in
++++ b/ext/srtp/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -775,7 +777,7 @@ glib_gen_basename = gstsrtp
+ BUILT_SOURCES = gstsrtp-enumtypes.c gstsrtp-enumtypes.h
+ nodist_libgstsrtp_la_SOURCES = $(BUILT_SOURCES)
+ CLEANFILES = $(BUILT_SOURCES)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n${H}include \"$(h)\")
+ all: $(BUILT_SOURCES)
+       $(MAKE) $(AM_MAKEFLAGS) all-am
+diff --git a/ext/webrtc/Makefile.in b/ext/webrtc/Makefile.in
+index da8fd9a..ec3588f 100644
+--- a/ext/webrtc/Makefile.in
++++ b/ext/webrtc/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -805,7 +807,7 @@ libgstwebrtc_la_LIBADD = \
+ libgstwebrtc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+ libgstwebrtc_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n${H}include \"$(h)\")
+ all: all-am
+ .SUFFIXES:
+diff --git a/gst-libs/gst/interfaces/Makefile.in b/gst-libs/gst/interfaces/Makefile.in
+index ca1bde5..9d54c2e 100644
+--- a/gst-libs/gst/interfaces/Makefile.in
++++ b/gst-libs/gst/interfaces/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -773,7 +775,7 @@ glib_enum_define = GST_PHOTOGRAPHY
+ glib_gen_prefix = gst_photography
+ glib_gen_basename = photography
+ glib_gen_decl_banner = GST_PHOTOGRAPHY_API
+-glib_gen_decl_include = \#include <gst/interfaces/photography-prelude.h>
++glib_gen_decl_include = ${H}include <gst/interfaces/photography-prelude.h>
+ built_sources = \
+       photography-enumtypes.c
+@@ -806,7 +808,7 @@ BUILT_SOURCES = \
+       $(built_headers)
+ CLEANFILES = $(BUILT_SOURCES)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n${H}include \"$(h)\")
+ all: $(BUILT_SOURCES)
+       $(MAKE) $(AM_MAKEFLAGS) all-am
+diff --git a/gst-libs/gst/mpegts/Makefile.in b/gst-libs/gst/mpegts/Makefile.in
+index 7a145cb..91a81cc 100644
+--- a/gst-libs/gst/mpegts/Makefile.in
++++ b/gst-libs/gst/mpegts/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -822,7 +824,7 @@ glib_enum_define = GST_MPEGTS
+ glib_gen_prefix = gst_mpegts
+ glib_gen_basename = gstmpegts
+ glib_gen_decl_banner = GST_MPEGTS_API
+-glib_gen_decl_include = \#include <gst/mpegts/mpegts-prelude.h>
++glib_gen_decl_include = ${H}include <gst/mpegts/mpegts-prelude.h>
+ BUILT_SOURCES = gstmpegts-enumtypes.c gstmpegts-enumtypes.h
+ nodist_libgstmpegts_@GST_API_VERSION@_la_SOURCES = gstmpegts-enumtypes.c
+ CLEANFILES = $(BUILT_SOURCES) $(am__append_1)
+@@ -842,7 +844,7 @@ CLEANFILES = $(BUILT_SOURCES) $(am__append_1)
+ @HAVE_INTROSPECTION_TRUE@gir_DATA = $(BUILT_GIRSOURCES)
+ @HAVE_INTROSPECTION_TRUE@typelibsdir = $(libdir)/girepository-1.0/
+ @HAVE_INTROSPECTION_TRUE@typelibs_DATA = $(BUILT_GIRSOURCES:.gir=.typelib)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n${H}include \"$(h)\")
+ all: $(BUILT_SOURCES)
+       $(MAKE) $(AM_MAKEFLAGS) all-am
+diff --git a/gst-libs/gst/webrtc/Makefile.in b/gst-libs/gst/webrtc/Makefile.in
+index 04146bc..1d0db28 100644
+--- a/gst-libs/gst/webrtc/Makefile.in
++++ b/gst-libs/gst/webrtc/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -761,7 +763,7 @@ glib_enum_define = GST_WEBRTC
+ glib_gen_prefix = gst_webrtc
+ glib_gen_basename = webrtc
+ glib_gen_decl_banner = GST_WEBRTC_API
+-glib_gen_decl_include = \#include <gst/webrtc/webrtc_fwd.h>
++glib_gen_decl_include = ${H}include <gst/webrtc/webrtc_fwd.h>
+ built_sources = webrtc-enumtypes.c
+ built_headers = webrtc-enumtypes.h
+ BUILT_SOURCES = $(built_sources) $(built_headers)
+@@ -807,7 +809,7 @@ libgstwebrtc_@GST_API_VERSION@_la_LDFLAGS = \
+       $(GST_ALL_LDFLAGS) \
+       $(GST_LT_LDFLAGS)
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n${H}include \"$(h)\")
+ @HAVE_INTROSPECTION_TRUE@BUILT_GIRSOURCES = GstWebRTC-@GST_API_VERSION@.gir
+ @HAVE_INTROSPECTION_TRUE@gir_headers = $(patsubst %,$(srcdir)/%, $(libgstwebrtc_@GST_API_VERSION@include_HEADERS))
+ @HAVE_INTROSPECTION_TRUE@gir_sources = $(patsubst %,$(srcdir)/%, $(libgstwebrtc_@GST_API_VERSION@_la_SOURCES)) $(BUILT_SOURCES)
diff --git a/media-plugins/gst-plugins-srtp/gst-plugins-srtp-1.16.2.ebuild b/media-plugins/gst-plugins-srtp/gst-plugins-srtp-1.16.2.ebuild
new file mode 100644 (file)
index 0000000..9f9edeb
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="SRTP encoder/decoder plugin for GStreamer"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=net-libs/libsrtp-2.1.0:2=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-util/glib-utils"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.16.2-make43.patch # remove when bumping and switching to Meson
+)