sys-kernel/gentoo-sources: bup
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 22 Jan 2017 21:36:04 +0000 (15:36 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 22 Jan 2017 21:40:38 +0000 (15:40 -0600)
Package-Manager: portage-2.3.0

sys-kernel/gentoo-sources/gentoo-sources-4.4.44.ebuild [new file with mode: 0644]

diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.4.44.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.4.44.ebuild
new file mode 100644 (file)
index 0000000..040ac35
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="47"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+       kernel-2_pkg_postinst
+       einfo "For more info on this patchset, and how to report problems, see:"
+       einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+       kernel-2_pkg_postrm
+}