net-im/toxic: correct dependency wrt bug 610570
authorDaniel Campbell <zlg@gentoo.org>
Fri, 24 Feb 2017 01:05:58 +0000 (17:05 -0800)
committerDaniel Campbell <zlg@gentoo.org>
Fri, 24 Feb 2017 01:05:58 +0000 (17:05 -0800)
Gentoo-Bug: 610570
Gentoo-Bug-URL: https://bugs.gentoo.org/610570

Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-im/toxic/toxic-0.7.2-r1.ebuild [new file with mode: 0644]

diff --git a/net-im/toxic/toxic-0.7.2-r1.ebuild b/net-im/toxic/toxic-0.7.2-r1.ebuild
new file mode 100644 (file)
index 0000000..27b588f
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A curses-based client for Tox."
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X +av notifications"
+
+RDEPEND="
+       net-libs/tox:0/0.1[av?]
+       dev-libs/libconfig
+       media-gfx/qrencode
+       net-misc/curl
+       sys-libs/ncurses:0=
+       av? ( media-libs/openal media-libs/freealut )
+       notifications? ( x11-libs/libnotify )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       if ! use av; then
+               export DISABLE_AV=1
+               export DISABLE_SOUND_NOTIFY=1
+       fi
+       if ! use X; then
+               export DISABLE_X11=1
+       fi
+       if ! use notifications; then
+               export DISABLE_DESKTOP_NOTIFY=1
+       fi
+       sed -i \
+               -e "s,/usr/local,${EPREFIX}/usr,g" \
+               cfg/global_vars.mk || die "PREFIX sed failed"
+}
+
+src_install() {
+       default
+       if ! use av; then
+               rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sound dir"
+       fi
+}