Version bump. This version should finally solve the hang on DirectFB shutdown issues...
authorMichele Noberasco <s4t4n@gentoo.org>
Tue, 24 Oct 2006 07:04:15 +0000 (07:04 +0000)
committerMichele Noberasco <s4t4n@gentoo.org>
Tue, 24 Oct 2006 07:04:15 +0000 (07:04 +0000)
Package-Manager: portage-2.1.1

sys-apps/qingy/ChangeLog
sys-apps/qingy/files/digest-qingy-0.9.2 [new file with mode: 0644]
sys-apps/qingy/files/qingy-logrotate [new file with mode: 0644]
sys-apps/qingy/qingy-0.9.2.ebuild [new file with mode: 0644]

index 82c2c507a4ba2c458fffff7280abea05db658273..73eb37c7facc4c0838e316ed1388dec77bd0b215 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for sys-apps/qingy
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.35 2006/10/13 10:39:24 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.36 2006/10/24 07:04:15 s4t4n Exp $
+
+*qingy-0.9.2 (24 Oct 2006)
+
+  24 Oct 2006; Michele Noberasco <s4t4n@gentoo.org> qingy-0.9.2.ebuild:
+  Version bump. This version should finally solve the shutdown hang issues.
+  qingy-0.9.1.ebuild:
+  Wiped out previous release...
 
   13 Oct 2006; Michele Noberasco <s4t4n@gentoo.org> qingy-0.7.4.ebuild,
   qingy-0.9.1.ebuild:
diff --git a/sys-apps/qingy/files/digest-qingy-0.9.2 b/sys-apps/qingy/files/digest-qingy-0.9.2
new file mode 100644 (file)
index 0000000..46160fd
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 3aea7f95ca80d8d65e428068c447609a qingy-0.9.2.tar.bz2 610406
+RMD160 3af52219bfe0466dcf9630f63503147eb2d92c26 qingy-0.9.2.tar.bz2 610406
+SHA256 31628bc3d85aa2469d80d016e7c30b4acd39c0ef02d40229db2dae9c8f59f6e8 qingy-0.9.2.tar.bz2 610406
+MD5 67510c456345db3be0f146257d445cce qingy-gentoo-theme.tar.bz2 147139
+RMD160 d0b5aae66ecb1d473c1e6b1e003e45834e82e469 qingy-gentoo-theme.tar.bz2 147139
+SHA256 a5b01b1d6ed8a008d3a6f0bc59c58c47dac914a7e4cd641864493c96c70dfac7 qingy-gentoo-theme.tar.bz2 147139
diff --git a/sys-apps/qingy/files/qingy-logrotate b/sys-apps/qingy/files/qingy-logrotate
new file mode 100644 (file)
index 0000000..f4acb30
--- /dev/null
@@ -0,0 +1,6 @@
+/var/log/qingy.log {
+    missingok
+    rotate 5
+    size 100k
+    weekly
+}
diff --git a/sys-apps/qingy/qingy-0.9.2.ebuild b/sys-apps/qingy/qingy-0.9.2.ebuild
new file mode 100644 (file)
index 0000000..7c34c7d
--- /dev/null
@@ -0,0 +1,130 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.2.ebuild,v 1.1 2006/10/24 07:04:15 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="a DirectFB getty replacement"
+HOMEPAGE="http://qingy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+       mirror://gentoo/${PN}-gentoo-theme.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="crypto_openssl crypto_libgcrypt directfb emacs gpm logrotate pam static X"
+
+RDEPEND=">=sys-libs/ncurses-5.4-r6
+       crypto_openssl?   ( >=dev-libs/openssl-0.9.7e )
+       crypto_libgcrypt? ( >=dev-libs/libgcrypt-1.2.1 )
+       directfb?         ( >=dev-libs/DirectFB-0.9.24 )
+       emacs?            ( virtual/emacs )
+       pam?              ( >=sys-libs/pam-0.75-r11 )
+       X?                ( || ( (
+                                  x11-libs/libX11
+                                  x11-libs/libXScrnSaver
+                                  x11-proto/scrnsaverproto )
+                                  virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+       >=dev-util/pkgconfig-0.12.0
+       >=sys-apps/sed-4.1.4-r1"
+
+src_unpack()
+{
+       if use crypto_openssl && use crypto_libgcrypt; then
+               echo
+               eerror "You can have openssl or libgcrypt as a crypto library, not both."
+               eerror "Please check your USE flags..."
+               echo
+               die "USE flags check failed"
+       fi
+
+       if use directfb; then
+
+               #Issues with this version have been work-arounded :-)
+               #if has_version "=dev-libs/DirectFB-0.9.25.1"; then
+               #       echo
+               #       ewarn "You are running DirectFB version 0.9.25.1:"
+               #       ewarn "I advise against that as this version introduces"
+               #       ewarn "instability, expecially when closing DirectFB mode!"
+               #       ewarn "Please consider downgrading DirectFB to version 0.9.24..."
+               #       echo
+               #       epause
+               #fi
+
+               if ! built_with_use -a DirectFB fbcon jpeg png truetype; then
+                       echo
+                       eerror "qingy expects DirectFB to provide certain capabilities."
+                       eerror "It depends on the theme you use, but at least the following USE flags"
+                       eerror "should be enabled in DirectFB: fbcon jpeg png truetype."
+                       eerror "You must rebuild DirectFB those USE flags enabled!"
+                       echo
+                       die "USE flags check failed"
+               fi
+
+       fi
+
+       unpack ${A}
+}
+
+src_compile()
+{
+       local crypto_support="--disable-crypto"
+
+       use crypto_openssl   && crypto_support="--enable-crypto=openssl"
+       use crypto_libgcrypt && crypto_support="--enable-crypto=libgcrypt"
+
+       econf                                      \
+               --sbindir=/sbin                        \
+               --disable-optimizations                \
+               `use_enable emacs`                     \
+               `use_enable pam`                       \
+               `use_enable static static-build`       \
+               `use_enable gpm gpm-lock`              \
+               `use_enable X x-support`               \
+               `use_enable directfb DirectFB-support` \
+               ${crypto_support}                      \
+               || die "Configuration failed"
+       emake || die "Compilation failed"
+}
+
+src_install()
+{
+       # Copy documentation manually as make install only installs info files
+       # INSTALL is left because it contains also configuration informations
+       dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
+
+       # Install the program
+       make DESTDIR=${D} install || die "Installation failed"
+
+       # Set the settings file umask to 600, in case somebody
+       # wants to make use of the autologin feature
+       /bin/chmod 600 ${D}/etc/qingy/settings
+
+       # Install Gentoo theme
+       dodir /usr/share/${PN}/themes/gentoo
+       cp ${WORKDIR}/gentoo/* ${D}/usr/share/${PN}/themes/gentoo \
+               || die "Gentoo theme installation failed"
+
+       # Alter config file so that it uses our theme
+       sed -i 's/theme = "default"/theme = "gentoo"/' ${D}/etc/${PN}/settings
+
+       # Install log rotation policy if user wants it
+       if use logrotate; then
+               insinto /etc/logrotate.d
+               newins ${FILESDIR}/${PN}-logrotate ${PN} || die "Log rotation policy installation failed"
+       fi
+}
+
+pkg_postinst()
+{
+       einfo "In order to use qingy you must first edit your /etc/inittab"
+       einfo "Check the documentation at ${HOMEPAGE}"
+       einfo "for instructions on how to do that."
+
+       if use crypto_libgcrypt; then
+               echo
+               einfo "You will have to create a key pair using 'qingy-keygen'"
+       fi
+}