dev-python/python_orocos_kdl: remove old
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 10:44:33 +0000 (11:44 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:26:50 +0000 (12:26 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/python_orocos_kdl/Manifest
dev-python/python_orocos_kdl/files/gentoo.patch [deleted file]
dev-python/python_orocos_kdl/files/py3.patch [deleted file]
dev-python/python_orocos_kdl/python_orocos_kdl-1.3.0-r2.ebuild [deleted file]

index a695dc0384dde9001434faaaea0841cf44b4db8f..a441a3f027e26597e992849ae6bcbca008d1299f 100644 (file)
@@ -1,2 +1 @@
-DIST orocos_kinematics_dynamics-1.3.0.tar.gz 200229 SHA256 7be2dd5e4f4c1ceac2cdf1f4fae3d94d4ffd9fc1af8d483c05f04e80ef84b3f9 SHA512 09ff63f74f1eac3ee8b1090364e0d95b4ae96c9d4435ca34adacb3ded7385f948ddca9be2c1c2c2214c9342b17bbffb7da89ba9b7cd402e7fd4f2c6dbd06a930 WHIRLPOOL 4085fa4aba77e0c24a3c1aab4ab5f98e8b349037525e6a596ff027075ea1dcd33c4f13fa3abd61bbe6a2a3bd13b62616d7b614c030ecda8343be3ed59406bae6
 DIST orocos_kinematics_dynamics-1.3.1.tar.gz 202471 SHA256 aff361d2b4e2c6d30ae959308a124022eeef5dc5bea2ce779900f9b36b0537bd SHA512 93abd9dd5aef3710f784f9db8eea4738458bffa5295923993e2d77656c18f7354559412fb7eb5f1e9da7112de19aa36d3f0f68f149852f955bce960fd3b719e7 WHIRLPOOL b7b4d897f4d5f170b73fe5bb48e357051ae37a244b9c44e8c2f120d71fc75c80cc1f69d30cb1463bbe10658ba0af98965f18f3055436910f24ebaab0ce1bd8e7
diff --git a/dev-python/python_orocos_kdl/files/gentoo.patch b/dev-python/python_orocos_kdl/files/gentoo.patch
deleted file mode 100644 (file)
index 571ee03..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: python_orocos_kdl/CMakeLists.txt
-===================================================================
---- python_orocos_kdl.orig/CMakeLists.txt
-+++ python_orocos_kdl/CMakeLists.txt
-@@ -21,4 +21,5 @@ set(SIP_EXTRA_OPTIONS "-o")
- set(PYTHON_SITE_PACKAGES_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/${PYTHON_SITE_PACKAGES})
- add_sip_python_module(PyKDL PyKDL/PyKDL.sip ${orocos_kdl_LIBRARIES})
--install(FILES package.xml DESTINATION share/python_orocos_kdl)
-\ No newline at end of file
-+install(FILES package.xml DESTINATION share/python_orocos_kdl)
-+install(FILES package.xml DESTINATION share/ros_packages/python_orocos_kdl)
diff --git a/dev-python/python_orocos_kdl/files/py3.patch b/dev-python/python_orocos_kdl/files/py3.patch
deleted file mode 100644 (file)
index dd22f2d..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-Upstream status: Pending.
-https://github.com/orocos/orocos_kinematics_dynamics/pull/44
-
-Index: orocos_kinematics_dynamics-1.3.0/python_orocos_kdl/CMakeLists.txt
-===================================================================
---- orocos_kinematics_dynamics-1.3.0.orig/python_orocos_kdl/CMakeLists.txt
-+++ orocos_kinematics_dynamics-1.3.0/python_orocos_kdl/CMakeLists.txt
-@@ -8,7 +8,7 @@ link_directories(${orocos_kdl_LIBRARY_DI
- find_package(PythonInterp REQUIRED)
- find_package(PythonLibs ${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} REQUIRED)
--execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(plat_specific=True, prefix='')" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
-+execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(plat_specific=True, prefix=''))" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
- list(APPEND CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
- find_package(SIP REQUIRED)
- include(SIPMacros)
-Index: orocos_kinematics_dynamics-1.3.0/python_orocos_kdl/PyKDL/std_string.sip
-===================================================================
---- orocos_kinematics_dynamics-1.3.0.orig/python_orocos_kdl/PyKDL/std_string.sip
-+++ orocos_kinematics_dynamics-1.3.0/python_orocos_kdl/PyKDL/std_string.sip
-@@ -27,7 +27,7 @@
-     newstring = PyUnicode_DecodeUTF8(sipCpp->c_str(), sipCpp->length(), NULL);
-     if(newstring == NULL) {
-         PyErr_Clear();
--        newstring = PyString_FromString(sipCpp->c_str());
-+        newstring = PyUnicode_FromString(sipCpp->c_str());
-     }
-     return newstring;
- %End
-@@ -38,21 +38,27 @@
-     // If argument is a Unicode string, just decode it to UTF-8
-     // If argument is a Python string, assume it's UTF-8
-      if (sipIsErr == NULL)
-+#if PY_MAJOR_VERSION < 3
-         return (PyString_Check(sipPy) || PyUnicode_Check(sipPy));
-+#else
-+        return PyUnicode_Check(sipPy);
-+#endif
-      if (sipPy == Py_None) {
-         *sipCppPtr = new std::string;
-          return 1;
-      }
-      if (PyUnicode_Check(sipPy)) {
-         PyObject* s = PyUnicode_AsEncodedString(sipPy, "UTF-8", "");
--        *sipCppPtr = new std::string(PyString_AS_STRING(s));
-+        *sipCppPtr = new std::string(PyUnicode_AS_DATA(s));
-         Py_DECREF(s);
-         return 1;
-      }
-+#if PY_MAJOR_VERSION < 3
-      if (PyString_Check(sipPy)) {
-         *sipCppPtr = new std::string(PyString_AS_STRING(sipPy));
-         return 1;
-      }
-+#endif
-      return 0;
- %End
diff --git a/dev-python/python_orocos_kdl/python_orocos_kdl-1.3.0-r2.ebuild b/dev-python/python_orocos_kdl/python_orocos_kdl-1.3.0-r2.ebuild
deleted file mode 100644 (file)
index 040977f..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SCM="git-r3"
-       EGIT_REPO_URI="https://github.com/orocos/orocos_kinematics_dynamics"
-fi
-
-inherit ${SCM} python-r1 cmake-utils
-
-if [ "${PV#9999}" != "${PV}" ] ; then
-       KEYWORDS=""
-       SRC_URI=""
-else
-       KEYWORDS="~amd64 ~arm"
-       SRC_URI="https://github.com/orocos/orocos_kinematics_dynamics/archive/v${PV}.tar.gz -> orocos_kinematics_dynamics-${PV}.tar.gz"
-fi
-
-DESCRIPTION="Python bindings for KDL"
-HOMEPAGE="http://www.orocos.org/kdl"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
-       sci-libs/orocos_kdl
-       dev-python/sip[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/py3.patch" "${FILESDIR}/gentoo.patch" )
-
-if [ "${PV#9999}" != "${PV}" ] ; then
-       S=${WORKDIR}/${P}/python_orocos_kdl
-else
-       S=${WORKDIR}/orocos_kinematics_dynamics-${PV}/python_orocos_kdl
-fi
-
-src_configure() {
-       python_foreach_impl cmake-utils_src_configure
-}
-
-src_compile() {
-       python_foreach_impl cmake-utils_src_compile
-}
-
-src_test() {
-       python_foreach_impl cmake-utils_src_test
-}
-
-src_install() {
-       python_foreach_impl cmake-utils_src_install
-}