app-emulation/libvirt: Update live ebuild, ebuild maintenance
authorMatthias Maier <tamiko@gentoo.org>
Tue, 20 Mar 2018 16:48:17 +0000 (11:48 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 20 Mar 2018 16:48:17 +0000 (11:48 -0500)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

app-emulation/libvirt/libvirt-4.0.0.ebuild
app-emulation/libvirt/libvirt-4.1.0.ebuild
app-emulation/libvirt/libvirt-9999.ebuild

index bed41a07b0a5fd165ebad6235557f1fa576427b4..954c95e4157d34c6e5fe117bb8dc058da9960cd7 100644 (file)
@@ -9,7 +9,7 @@ if [[ ${PV} = *9999* ]]; then
        inherit git-r3
        EGIT_REPO_URI="git://libvirt.org/libvirt.git"
        SRC_URI=""
-       KEYWORDS="amd64 x86"
+       KEYWORDS=""
        SLOT="0"
 else
        # Versions with 4 numbers are stable updates:
index 24e65968e4f2bc67f4fd627020dd5762c1132ef0..deed4ffd7dbc95f181f668dbf0d2e466ea720a03 100644 (file)
@@ -9,7 +9,7 @@ if [[ ${PV} = *9999* ]]; then
        inherit git-r3
        EGIT_REPO_URI="git://libvirt.org/libvirt.git"
        SRC_URI=""
-       KEYWORDS="amd64 x86"
+       KEYWORDS=""
        SLOT="0"
 else
        # Versions with 4 numbers are stable updates:
index 0b482d5c1023a2f2156af914272df5139a925b01..7aff7685c70990a6e6b1ff1bbc0a310804f2af73 100644 (file)
@@ -58,6 +58,8 @@ RDEPEND="
        || ( >=net-analyzer/netcat6-1.0-r2 >=net-analyzer/openbsd-netcat-1.105-r1 )
        >=net-libs/gnutls-1.0.25:0=
        net-libs/libssh2
+       net-libs/libtirpc
+       net-libs/rpcsvc-proto
        >=net-misc/curl-7.18.0
        sys-apps/dmidecode
        >=sys-apps/util-linux-2.17
@@ -235,6 +237,12 @@ src_prepare() {
 }
 
 src_configure() {
+       #
+       # With 4.1.0 we should always enable networking support - otherwise not
+       # even minimal networking is available. Yes, this degrades
+       # USE=virt-network to a mere runtime-dep USE flag. But let's keep it
+       # for compatibility and convenience.
+       #
        local myeconfargs=(
                $(use_with apparmor)
                $(use_with apparmor apparmor-profiles)
@@ -268,7 +276,6 @@ src_configure() {
                $(use_with udev)
                $(use_with uml)
                $(use_with vepa virtualport)
-               $(use_with virt-network network)
                $(use_with wireshark-plugins wireshark-dissector)
                $(use_with xen)
                $(use_with xen xen-inotify)
@@ -276,6 +283,8 @@ src_configure() {
                $(use_with zeroconf avahi)
                $(use_with zfs storage-zfs)
 
+               --with-network
+
                --without-hal
                --without-netcf
                --without-sanlock