dev-lang/lisaac: port to EAPI=7
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 21 Mar 2020 11:29:04 +0000 (14:29 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 21 Mar 2020 11:29:27 +0000 (14:29 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-lang/lisaac/lisaac-0.13.1-r2.ebuild

index 7d7646984cb0513fe9ab312185e6f3d3d70c196b..10fca08c1796d47a71269393b98fdd90fdfff248 100644 (file)
@@ -1,10 +1,11 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
-inherit versionator elisp-common eutils toolchain-funcs
+EAPI=7
 
-DESCRIPTION="Lisaac is an object prototype based language"
+inherit elisp-common toolchain-funcs
+
+DESCRIPTION="An object prototype based language"
 HOMEPAGE="http://isaacproject.u-strasbg.fr/li.html"
 SRC_URI="http://isaacproject.u-strasbg.fr/download/${P}.tar.gz"
 
@@ -14,29 +15,29 @@ KEYWORDS="~amd64 ~x86"
 IUSE="vim-syntax emacs examples"
 
 DEPEND="vim-syntax? ( app-editors/vim )
-               emacs? ( >=app-editors/emacs-23.1 )"
+       emacs? ( >=app-editors/emacs-23.1 )"
 
 RDEPEND="${DEPEND}"
 
 SITEFILE=50${PN}-gentoo.el
 
 src_prepare() {
-       epatch "${FILESDIR}/${P}-makefile.patch"
-       rm lib/number/essai
+       default
+       eapply "${FILESDIR}/${P}-makefile.patch"
+       rm lib/number/essai || die
 }
 
 src_compile() {
        emake CC="$(tc-getCC)"
 
-       if use emacs; then
-               elisp-compile editor/emacs/lisaac-mode.el \
-                       || die "compiling emacs component failed."
-       fi
+       use emacs elisp-compile editor/emacs/lisaac-mode.el
 }
 
 src_install() {
        emake DESTDIR="${D}" DOC="/usr/share/doc/${PF}" install
 
+       gzip -d "${D}"/usr/share/man/man1/{lisaac,shorter}.1.gz || die
+
        if use vim-syntax; then
                insinto /usr/share/vim/vimfiles/syntax/
                doins editor/vim/syntax/lisaac.vim
@@ -45,15 +46,13 @@ src_install() {
        fi
 
        if use emacs; then
-               elisp-install ${PN} editor/emacs/*.{el,elc} \
-                       || die "installing emacs coponent failed."
-               elisp-site-file-install "${FILESDIR}"/${SITEFILE} \
-                       || die "installing emacs site file failed"
+               elisp-install ${PN} editor/emacs/*.{el,elc}
+               elisp-site-file-install "${FILESDIR}"/${SITEFILE}
        fi
 
        if use examples; then
-               dodir /usr/share/${PN}/
-               cp -r example "${ED}"/usr/share/${PN}/examples
+               dodir /usr/share/${PN}
+               cp -r example "${ED}"/usr/share/${PN}/examples || die
        fi
 }