Ported to PPC
authorPieter van den Abeele <pvdabeel@gentoo.org>
Sat, 25 Sep 2004 11:35:40 +0000 (11:35 +0000)
committerPieter van den Abeele <pvdabeel@gentoo.org>
Sat, 25 Sep 2004 11:35:40 +0000 (11:35 +0000)
dev-libs/hdf/Manifest
dev-libs/hdf/hdf-4.2.0-r3.ebuild

index bd611d3d376c1cf21a4cdadc6239fdb27cb2da5d..41d8bfc9eb02c34dd5cef96f1a58e44bfcd3217d 100644 (file)
@@ -1,6 +1,6 @@
-MD5 476b9ff044c3fbfc98e65e2cb568afc1 hdf-4.2.0-r3.ebuild 1645
-MD5 62e68d9c2222e914a7ed7babaa9532b6 hdf-4.2.0-r2.ebuild 1459
 MD5 1b34783073eb8dc69d1ae6797150c763 ChangeLog 1094
+MD5 62e68d9c2222e914a7ed7babaa9532b6 hdf-4.2.0-r2.ebuild 1459
 MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 08c41c112c61d6e345c509da1d856dfe hdf-4.2.0-r3.ebuild 1702
 MD5 bdb6c3501721a0f1f6b81f2f9b052028 files/digest-hdf-4.2.0-r2 61
 MD5 bdb6c3501721a0f1f6b81f2f9b052028 files/digest-hdf-4.2.0-r3 61
index f7ce6356b609886f49a526ace8eb6239c95aeba8..f7a9106150510d6819239a79e57fba32df27ea6a 100644 (file)
@@ -1,6 +1,8 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf/hdf-4.2.0-r3.ebuild,v 1.3 2004/06/24 23:12:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf/hdf-4.2.0-r3.ebuild,v 1.4 2004/09/25 11:35:40 pvdabeel Exp $
+
+inherit flag-o-matic
 
 # substitute second dot by "r"
 MY_PV=${PV/./X}
@@ -14,7 +16,7 @@ SRC_URI="ftp://ftp.ncsa.uiuc.edu/HDF/pub/outgoing/hdf4/hdf${MY_PV}/hdf${MY_PV}.t
 HOMEPAGE="http://hdf.ncsa.uiuc.edu/hdf4.html"
 
 LICENSE="NCSA-HDF"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~x86 ~amd64 ppc"
 SLOT="0"
 IUSE="szip"
 
@@ -33,6 +35,7 @@ pkg_setup() {
 src_compile() {
        local myconf="--enable-production"
        use szip && myconf="${myconf} --with-szlib=/usr"
+       use ppc && append-flags -DSUN
        econf ${myconf} || die "configure failed"
        make LDFLAGS="-lm" || die "make failed"
 }