dev-python/astunparse: new package, and astun parser for python
authorWilliam Hubbs <william.hubbs@sony.com>
Mon, 16 Dec 2019 22:53:22 +0000 (16:53 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 16 Dec 2019 22:53:57 +0000 (16:53 -0600)
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-python/astunparse/Manifest [new file with mode: 0644]
dev-python/astunparse/astunparse-1.6.2.ebuild [new file with mode: 0644]
dev-python/astunparse/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/astunparse/Manifest b/dev-python/astunparse/Manifest
new file mode 100644 (file)
index 0000000..ad72dea
--- /dev/null
@@ -0,0 +1 @@
+DIST astunparse-1.6.2.tar.gz 16339 BLAKE2B d35d63b8313718c1d873d55b7da824465be9b4bc9e486ff82dac7db2df5185f8a59bfb283844d7108927b04ee02879fe921c87f9da8bd87c157341e6022b40cc SHA512 1e344354481dab7345d8790791e15e2ce733b8985839972a1771b97adebbfc2b42c8fb258ea36f245baed553d3b8e5007872d6559ebcc5ef1eb6f6c6a5d66c81
diff --git a/dev-python/astunparse/astunparse-1.6.2.ebuild b/dev-python/astunparse/astunparse-1.6.2.ebuild
new file mode 100644 (file)
index 0000000..e1d5d1c
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Astun parser for python"
+HOMEPAGE="https://github.com/simonpercivall/astunparse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+       >=dev-python/wheel-0.23.0[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+       distutils-r1_python_install_all
+       dodoc *.rst
+}
diff --git a/dev-python/astunparse/metadata.xml b/dev-python/astunparse/metadata.xml
new file mode 100644 (file)
index 0000000..c36c371
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>williamh@gentoo.org</email>
+               <name>William Hubbs</name>
+       </maintainer>
+</pkgmetadata>