fix tests with patch from Dustin Polke (bug #527270)
authorMichael Sterrett <mr_bones_@gentoo.org>
Tue, 6 Oct 2015 18:47:54 +0000 (14:47 -0400)
committerMichael Sterrett <mr_bones_@gentoo.org>
Tue, 6 Oct 2015 18:48:08 +0000 (14:48 -0400)
Package-Manager: portage-2.2.20.1

media-libs/devil/devil-1.7.8-r2.ebuild
media-libs/devil/files/devil-1.7.8-fix-test.patch [new file with mode: 0644]

index c20974c63f48637341ae9af6868af0d347614d5f..43a592eb2b162f73ae3e251d29b346c74b020fad 100644 (file)
@@ -38,7 +38,7 @@ DEPEND="${RDEPEND}
        X? ( x11-proto/xextproto )"
 
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-{CVE-2009-3994,libpng14,nvtt-glut,ILUT,restrict}.patch
+       epatch "${FILESDIR}"/${P}-{CVE-2009-3994,libpng14,nvtt-glut,ILUT,restrict,fix-test}.patch
        eautoreconf
 }
 
diff --git a/media-libs/devil/files/devil-1.7.8-fix-test.patch b/media-libs/devil/files/devil-1.7.8-fix-test.patch
new file mode 100644 (file)
index 0000000..44af2fc
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/devil-1.7.8/test/Makefile.am
++++ b/devil-1.7.8/test/Makefile.am
+@@ -12,5 +12,6 @@ else
+ testil_LDADD += ../lib/libIL.la
+ endif
+-TESTS_ENVIRONMENT = /bin/bash
++TESTS_ENVIRONMENT =
+ TESTS = $(check_SCRIPTS)
++LOG_COMPILER = $(SHELL)