cmake-utils.eclass: Fix typo
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 19 May 2019 15:44:26 +0000 (17:44 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 4 Jul 2019 19:36:07 +0000 (21:36 +0200)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
eclass/cmake-utils.eclass

index d01a64d014af6e71cf9d87b690b9465a2819e5be..28dac7e0a0b44d813997848f8d4ad7ce9d1eac18 100644 (file)
@@ -423,7 +423,7 @@ _cmake_modify-cmakelists() {
                -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_BUILD_TYPE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
                -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_COLOR_MAKEFILE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
                -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_INSTALL_PREFIX[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
-               -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_VERBOSE_MAKEFILE[[:space:]].*)/I{s/^/#G_cmake_modify_IGNORE /g}' \
+               -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_VERBOSE_MAKEFILE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
                -i {} + || die "${LINENO}: failed to disable hardcoded settings"
        local x
        for x in $(find "${CMAKE_USE_DIR}" -name CMakeLists.txt -exec grep -l "^#_cmake_modify_IGNORE" {} +;); do