dev-python/denonavr: new package.
authorLouis Sautier <sautier.louis@gmail.com>
Sun, 17 Sep 2017 15:39:51 +0000 (17:39 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 22 Sep 2017 13:14:23 +0000 (15:14 +0200)
Automation Library for Denon AVR receivers.

Package-Manager: Portage-2.3.8, Repoman-2.3.3
Closes: https://github.com/gentoo/gentoo/pull/5716

dev-python/denonavr/Manifest [new file with mode: 0644]
dev-python/denonavr/denonavr-0.5.3.ebuild [new file with mode: 0644]
dev-python/denonavr/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
new file mode 100644 (file)
index 0000000..bbfb0d4
--- /dev/null
@@ -0,0 +1 @@
+DIST denonavr-0.5.3.tar.gz 60941 SHA256 8904bda0f6de1d40f602a26f909b592c33a82df4f22963f908168f6e031af585 SHA512 709f1eb2c51ba193ec17d3dc20d43d1f632a6e8b387b962e15b9b573c4d539357b3fd48cc177dd701b4b7043afdbab7a06a808b34b44e8c971f2f72ef6383d9b WHIRLPOOL 519f46898e1af12be5733c8d4cf2c0d65ecb191c283ac9b77f467680076b12f2749b5c183f823fda879e2f5ec855a36b67af3a95fd01b61a28a60e4092a16d19
diff --git a/dev-python/denonavr/denonavr-0.5.3.ebuild b/dev-python/denonavr/denonavr-0.5.3.ebuild
new file mode 100644 (file)
index 0000000..8c66944
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="https://github.com/scarface-4711/denonavr"
+# PyPI tarballs lack tests: https://github.com/scarface-4711/denonavr/pull/31
+SRC_URI="https://github.com/scarface-4711/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/requests-mock[${PYTHON_USEDEP}]
+               dev-python/testtools[${PYTHON_USEDEP}]
+               ${RDEPEND}
+       )
+"
+
+python_test() {
+       py.test ||  die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/denonavr/metadata.xml b/dev-python/denonavr/metadata.xml
new file mode 100644 (file)
index 0000000..aa718e5
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>sautier.louis@gmail.com</email>
+               <name>Louis Sautier</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">denonavr</remote-id>
+               <remote-id type="github">scarface-4711/denonavr</remote-id>
+               <bugs-to>https://github.com/scarface-4711/denonavr/issues</bugs-to>
+       </upstream>
+</pkgmetadata>