dev-python/utidylib: Drop 0.3-r2
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 1 Mar 2020 21:12:25 +0000 (22:12 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 1 Mar 2020 22:02:08 +0000 (23:02 +0100)
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/utidylib/Manifest
dev-python/utidylib/utidylib-0.3-r2.ebuild [deleted file]

index bbf80b3d44c7f5d73f48858a548dd60506924e1f..c64ef0996cdea3c4cae602b2ded083a69331822c 100644 (file)
@@ -1,2 +1 @@
-DIST uTidylib-0.3.tar.bz2 13809 BLAKE2B c6b495933ecdc21543c79e3ff200cc06ec4ebc1682cf9172bd988a08afef8b69db17eec4b88665aff5dc6cef371f3c665f6de3ffcc1dc515f778b523333c891b SHA512 4503f2a6366e5110740b312df2300d62bb68e1e1032184e9b56dee75995309c76d4f8e5851c73e7c8e08cca7bba9c74436d8dfc0524f115f3abb2bdf5529cc35
 DIST uTidylib-0.6.tar.gz 15771 BLAKE2B 9d4fe57d985ea6e52680bd528862d3236137221227a23fe05b886d01d240e21d7159dbf7d6da3af8020009ca45c60c2297e374bb7aa05cb6b5a8eaf444710c58 SHA512 a85506ef8824f66ee326ad651020dc3b4e00190e20dcd3814984fa27ff319f492fe5bac781b7c43c8694cbfc63409e3abda18981969c9be2c3cd023fe7a4f2f8
diff --git a/dev-python/utidylib/utidylib-0.3-r2.ebuild b/dev-python/utidylib/utidylib-0.3-r2.ebuild
deleted file mode 100644 (file)
index fca127c..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_P="uTidylib-${PV}"
-
-DESCRIPTION="TidyLib Python wrapper"
-HOMEPAGE="https://cihar.com/software/utidylib/"
-SRC_URI="http://dl.cihar.com/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc ppc64 x86"
-IUSE="doc test"
-
-RDEPEND="
-       app-text/tidy-html5
-       dev-python/six[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-RESTRICT="test"        # 1/11 tests fail
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
-       if use doc; then
-               ${EPYTHON} setup.py build_sphinx || die
-       fi
-}
-
-python_test() {
-       py.test || die "testsuite failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( build/sphinx/html/. )
-       distutils-r1_python_install_all
-}