dev-python/python-twitter: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:04:14 +0000 (22:04 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:11:20 +0000 (22:11 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-twitter/Manifest
dev-python/python-twitter/python-twitter-3.3.ebuild [deleted file]

index 035d9eb01d140d554f53a99d77e4bd94b974c645..e2af08ff08bb413b83f3edbb3ee68b77c2a45582 100644 (file)
@@ -1,2 +1 @@
-DIST python-twitter-3.3.tar.gz 84696 BLAKE2B aad833904e0127fca4043bf66187e7ff5a4175c7c86cf9b053c7d0bc6c9f25d2bc102a631d479ebd4ce81b515aea0f058473993a1b7f5a03751dd83f39e9a3c3 SHA512 72e4133abddf86a19b8701f846df7eb99b426b8835e457455935a656f38c266fb2930d8a145d5d280ef2e0f0096511b29dcdf98b94bd53b6a661ea575cfb3265
 DIST python-twitter-3.4.2.tar.gz 5145121 BLAKE2B 2ac45ae8fde3cfccb794d8496efdb0066c887101b6a6ac55ad6fd0f9fda8f50db1245284236c5fa0fd8eb7419c11eb253777d78092ea138d2f0a5115db861a89 SHA512 23d009e006864bb9dbf9c10223531a0e2aeefd4ca59852849f49f41e36b6db29e820a58c8a43f23c7bda0c68b6eb19a5557ef649bae2cbb1f1e406f78a918f92
diff --git a/dev-python/python-twitter/python-twitter-3.3.ebuild b/dev-python/python-twitter/python-twitter-3.3.ebuild
deleted file mode 100644 (file)
index a317ab9..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper around the Twitter API"
-HOMEPAGE="https://github.com/bear/python-twitter"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-macos"
-IUSE="examples"
-
-RDEPEND="
-       dev-python/oauth2[${PYTHON_USEDEP}]
-       dev-python/simplejson[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       dev-python/requests-oauthlib[${PYTHON_USEDEP}]"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# Testsuite is still not convincing in its completeness
-RESTRICT="test"
-
-src_prepare() {
-       distutils-r1_src_prepare
-}
-
-# https://code.google.com/p/python-twitter/issues/detail?id=259&thanks=259&ts=1400334214
-python_test() {
-       esetup.py test
-}