QA: which -> type -P
authorDanny van Dyk <kugelfang@gentoo.org>
Tue, 13 Mar 2007 00:29:07 +0000 (00:29 +0000)
committerDanny van Dyk <kugelfang@gentoo.org>
Tue, 13 Mar 2007 00:29:07 +0000 (00:29 +0000)
Package-Manager: portage-2.1.2.1-r1

sci-libs/blas-atlas/ChangeLog
sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild
sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild
sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild
sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild
sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
sci-libs/lapack-atlas/ChangeLog
sci-libs/lapack-atlas/lapack-atlas-3.6.0.ebuild
sci-libs/lapack-reference/ChangeLog
sci-libs/lapack-reference/lapack-reference-3.0.ebuild

index b4db45af41ab6ab4e01400aebd1fb77d93521c56..f21fa3de4a3446768890f91254580a7ec8dff12f 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sci-libs/blas-atlas
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.54 2007/01/23 14:01:50 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.55 2007/03/13 00:24:34 kugelfang Exp $
+
+  13 Mar 2007; Danny van Dyk <kugelfang@gentoo.org> blas-atlas-3.6.0.ebuild,
+  blas-atlas-3.6.0-r1.ebuild, blas-atlas-3.6.0-r2.ebuild,
+  blas-atlas-3.7.11.ebuild, blas-atlas-3.7.11-r1.ebuild:
+  QA: which -> type -P
 
   23 Jan 2007; Markus Dittrich <markusle@gentoo.org>
   -blas-atlas-3.7.23.ebuild:
index 09312f1962c6dbb04871452d355c9fc033327615..81bf08e6134fb182a097942756b1814473832a4f 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild,v 1.11 2006/06/17 00:34:47 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild,v 1.12 2007/03/13 00:24:34 kugelfang Exp $
 
 inherit eutils toolchain-funcs
 
@@ -24,13 +24,13 @@ PROVIDE="virtual/blas"
 
 S=${WORKDIR}/ATLAS
 
-# Libraries will be installed in ${RPATH}/atlas 
+# Libraries will be installed in ${RPATH}/atlas
 # and ${RPATH}/threaded-atlas:
 RPATH="${DESTTREE}/lib/blas"
 
 
 pkg_setup() {
-       if [ -z `which g77` ]; then
+       if [[ -z `type -P g77` ]]; then
                eerror "No fortran compiler found on the system!"
                eerror "Please add fortran to your USE flags and reemerge gcc!"
                die
index 7901075df308d17d000f872353b294f9c89fb6ad..9937dda3c0d73f5ace72e541797b136f8bb3e1ce 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild,v 1.3 2006/08/17 18:22:29 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild,v 1.4 2007/03/13 00:24:34 kugelfang Exp $
 
 inherit eutils toolchain-funcs
 
@@ -25,13 +25,13 @@ PROVIDE="virtual/blas"
 
 S=${WORKDIR}/ATLAS
 
-# Libraries will be installed in ${RPATH}/atlas 
+# Libraries will be installed in ${RPATH}/atlas
 # and ${RPATH}/threaded-atlas:
 RPATH="${DESTTREE}/lib/blas"
 
 
 pkg_setup() {
-       if [ -z `which g77` ]; then
+       if [[ -z `type -P g77` ]]; then
                eerror "No fortran compiler found on the system!"
                eerror "Please add fortran to your USE flags and reemerge gcc!"
                die
index f6b83f8f0b5937bc48d7361fc2be8b77e2b1179f..ec00f42ed9e459d938e7e35dc31f3db51e5ca983 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.7 2006/01/28 15:32:30 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.8 2007/03/13 00:24:34 kugelfang Exp $
 
 inherit eutils toolchain-funcs
 
@@ -25,7 +25,7 @@ PROVIDE="virtual/blas"
 S=${WORKDIR}/ATLAS
 
 pkg_setup() {
-       if [ -z `which g77` ]; then
+       if [[ -z `type -P g77` ]]; then
                eerror "No fortran compiler found on the system!"
                eerror "Please add fortran to your USE flags and reemerge gcc!"
                die
index a7a6d2434387304a3efabaf1edff035f993211bd..c93c241fc8183ae5e351362a720590c50ffa01b8 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild,v 1.7 2006/10/04 14:52:26 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild,v 1.8 2007/03/13 00:24:34 kugelfang Exp $
 
 inherit eutils toolchain-funcs fortran
 
@@ -164,8 +164,8 @@ src_install () {
        doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h
        doins "${S}"/include/atlas_enum.h
 
-       # These headers contain the architecture-specific 
-       # optimizations determined by ATLAS. The atlas-lapack build 
+       # These headers contain the architecture-specific
+       # optimizations determined by ATLAS. The atlas-lapack build
        # is much shorter if they are available, so save them:
        doins "${S}/include/${ATLAS_ARCH}"/*.h
 
index b091b35730e25188c85a6a413b1de49b9b3dd33f..82ad54e8ab09c712d1b93d4fe3fe905489a650b2 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild,v 1.17 2007/01/03 02:36:46 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild,v 1.18 2007/03/13 00:24:34 kugelfang Exp $
 
 inherit eutils toolchain-funcs fortran
 
@@ -165,8 +165,8 @@ src_install () {
        doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h
        doins "${S}"/include/atlas_enum.h
 
-       # These headers contain the architecture-specific 
-       # optimizations determined by ATLAS. The atlas-lapack build 
+       # These headers contain the architecture-specific
+       # optimizations determined by ATLAS. The atlas-lapack build
        # is much shorter if they are available, so save them:
        doins "${S}/include/${ATLAS_ARCH}"/*.h
 
index 8c893acf132c7f59a70dc6c70bcf5dd44b8f51c5..32e203b594a335dde3db36c74e3d6a5ea9810c44 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sci-libs/lapack-atlas
 # Copyright 2004-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.38 2007/02/06 21:31:02 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.39 2007/03/13 00:27:07 kugelfang Exp $
+
+  13 Mar 2007; Danny van Dyk <kugelfang@gentoo.org>
+  lapack-atlas-3.6.0.ebuild:
+  QA: which -> type -P
 
 *lapack-atlas-3.7.24-r1 (06 Feb 2007)
 
index 6681d7f00cd190e11df0821e7f99d3f888256770..40c8e5edd8a94b3db81347e2c949c99b35cafbea 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.6.0.ebuild,v 1.11 2007/01/23 13:57:22 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.6.0.ebuild,v 1.12 2007/03/13 00:27:07 kugelfang Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -61,7 +61,7 @@ pkg_setup() {
        # We need g77 to compile the LAPACK routines from ATLAS.
        # `use ifc` only causes the non-ATLAS routines (from the
        #  reference set) to be built with ifc.
-       if [ -z `which g77` ]; then
+       if [[ -z `type -P g77` ]]; then
                eerror "g77 not found on the system!"
                eerror "Please add fortran to your USE flags and reemerge gcc!"
                die
index 8162c371b90a5fac818971d75a4a0b728b1a873a..44cc6c14aad183f3e9f2eb1ed67a07641474590d 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sci-libs/lapack-reference
 # Copyright 2004-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/ChangeLog,v 1.17 2007/03/09 12:30:38 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/ChangeLog,v 1.18 2007/03/13 00:29:07 kugelfang Exp $
+
+  13 Mar 2007; Danny van Dyk <kugelfang@gentoo.org>
+  lapack-reference-3.0.ebuild:
+  QA: which -> type -P
 
 *lapack-reference-3.1.1 (08 Mar 2007)
 
index fa2b51f8dc98fb35c1391159cd70dac9362a4294..d8edee0991ed5641280aec1c63eda4d6a8cc370c 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.0.ebuild,v 1.5 2007/01/23 13:46:09 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.0.ebuild,v 1.6 2007/03/13 00:29:07 kugelfang Exp $
 
 inherit eutils
 
@@ -49,7 +49,7 @@ ifc_info() {
 pkg_setup() {
        # This version of lapack *can* be build completely with ifc
        use ifc || \
-       if [ -z `which g77` ]; then
+       if [[ -z `type -P g77` ]]; then
                eerror "g77 not found on the system!"
                eerror "Please add fortran to your USE flags and reemerge gcc!"
                die