net-wireless/bluez: More kernel options are needed
authorPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 18:26:29 +0000 (19:26 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 18:27:12 +0000 (19:27 +0100)
Closes: https://bugs.gentoo.org/704190
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
net-wireless/bluez/bluez-5.53.ebuild

index 6535d303da2ad06c6e43fecc2ad0ef68a3f47763..f5a2961f9764ff9ed5f3998ead1100a443c45f26 100644 (file)
@@ -78,6 +78,13 @@ pkg_setup() {
        # https://bugzilla.kernel.org/show_bug.cgi?id=196621
        CONFIG_CHECK="~NET ~BT ~BT_RFCOMM ~BT_RFCOMM_TTY ~BT_BNEP ~BT_BNEP_MC_FILTER
                                ~BT_BNEP_PROTO_FILTER ~BT_HIDP ~RFKILL"
+       # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+       # https://bugzilla.kernel.org/show_bug.cgi?id=206815
+       if use mesh || use test; then
+               CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_USER
+               ~CRYPTO_USER_API ~CRYPTO_USER_API_AEAD ~CRYPTO_USER_API_HASH
+               ~CRYPTO_AES ~CRYPTO_CCM ~CRYPTO_AEAD ~CRYPTO_CMAC"
+       fi
        if use test; then
                CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO ~CRYPTO_USER_API_HASH ~CRYPTO_USER_API_SKCIPHER"
        fi
@@ -110,10 +117,6 @@ src_prepare() {
                        Makefile.{in,tools} || die
        fi
 
-       # Broken test: https://bugzilla.kernel.org/show_bug.cgi?id=206815
-       # https://bugs.gentoo.org/704190
-        sed -i -e '/unit_tests += unit\/test-mesh-crypto\b/d' Makefile.am || die
-
        eautoreconf
 
        multilib_copy_sources