sys-power/acpilight: New Package
authorBrian Evans <grknight@gentoo.org>
Mon, 22 Aug 2016 20:09:55 +0000 (16:09 -0400)
committerBrian Evans <grknight@gentoo.org>
Mon, 22 Aug 2016 20:11:08 +0000 (16:11 -0400)
Package-Manager: portage-2.3.0

sys-power/acpilight/Manifest [new file with mode: 0644]
sys-power/acpilight/acpilight-0_pre20160724.ebuild [new file with mode: 0644]
sys-power/acpilight/files/90-backlight.rules [new file with mode: 0644]
sys-power/acpilight/metadata.xml [new file with mode: 0644]

diff --git a/sys-power/acpilight/Manifest b/sys-power/acpilight/Manifest
new file mode 100644 (file)
index 0000000..ba2fb47
--- /dev/null
@@ -0,0 +1 @@
+DIST acpilight-0_pre20160724.tar.gz 2125 SHA256 d57f71561fd73289c3b81332c08619ac3edcc295bcfe7fd1840e512d00e0835b SHA512 a249f46afcb2f45c6f85769e4c6de1751da4cb432012db51b8682a7dc1454fe2cffbe5694ea18bdc275b4c302f911b68f104d3e7b4c8e9b8ac114cbecc91fc56 WHIRLPOOL 57a2f01a74046662102fe35715b161ef94ffb83db038547424d99f95cee3b432b2151fd7c7b7cde3b1dd19cfa339548c8c3b795c440dba24e48a31760b645c0a
diff --git a/sys-power/acpilight/acpilight-0_pre20160724.ebuild b/sys-power/acpilight/acpilight-0_pre20160724.ebuild
new file mode 100644 (file)
index 0000000..f67bcb0
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit python-r1 udev vcs-snapshot
+
+VCS_COMMIT="4a15c2d3019aacd891e7d2151334e22b2cebe0ca"
+DESCRIPTION="Replacement for xbacklight that uses the ACPI interface to set brightness"
+HOMEPAGE="https://github.com/wavexx/acpilight/"
+SRC_URI="https://github.com/wavexx/acpilight/archive/${VCS_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev
+       ${PYTHON_DEPS}
+       !x11-apps/xbacklight"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( README.rst )
+
+src_install() {
+       python_foreach_impl python_doscript xbacklight
+       udev_dorules "${FILESDIR}"/90-backlight.rules
+       einstalldocs
+}
+
+pkg_postinst() {
+       udev_reload
+       einfo
+       elog "To use the xbacklight binary as a regular user, you must be a part of the video group"
+       einfo
+       elog "If this utility does not find any backlights to manipulate,"
+       elog "verify you have kernel support on the device and display driver enabled."
+       einfo
+}
diff --git a/sys-power/acpilight/files/90-backlight.rules b/sys-power/acpilight/files/90-backlight.rules
new file mode 100644 (file)
index 0000000..9f5b1c8
--- /dev/null
@@ -0,0 +1,2 @@
+SUBSYSTEM=="backlight", ACTION=="add", RUN+="/bin/chgrp video /sys/class/backlight/%k/brightness"
+SUBSYSTEM=="backlight", ACTION=="add", RUN+="/bin/chmod g+w /sys/class/backlight/%k/brightness"
diff --git a/sys-power/acpilight/metadata.xml b/sys-power/acpilight/metadata.xml
new file mode 100644 (file)
index 0000000..1454e21
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>grknight@gentoo.org</email>
+    <name>Brian Evans</name>
+  </maintainer>
+</pkgmetadata>